summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/abook/abook-0.6.0_pre2.ebuild')
-rw-r--r--app-misc/abook/abook-0.6.0_pre2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-misc/abook/abook-0.6.0_pre2.ebuild b/app-misc/abook/abook-0.6.0_pre2.ebuild
index e383d809c9ba..e3d70b02b5a6 100644
--- a/app-misc/abook/abook-0.6.0_pre2.ebuild
+++ b/app-misc/abook/abook-0.6.0_pre2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -32,6 +32,11 @@ src_configure() {
econf $(use_enable nls)
}
+src_compile() {
+ # bug 570428
+ emake CFLAGS="${CFLAGS} -std=gnu89"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc BUGS ChangeLog FAQ README TODO sample.abookrc || die "dodoc failed"