summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild')
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
new file mode 100644
index 000000000000..6de9a0bd56b9
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}