summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/countrycodes/countrycodes-1.0.6.ebuild')
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/countrycodes/countrycodes-1.0.6.ebuild b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
new file mode 100644
index 000000000000..4238cde9269e
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="https://sourceforge.net/projects/countrycodes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
+
+PATCHES=( "${FILESDIR}"/${PV}-Makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man install
+ dosym iso3166 /usr/bin/countrycodes
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc README
+}