summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mepl/mepl-0.45-r2.ebuild')
-rw-r--r--app-misc/mepl/mepl-0.45-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/mepl/mepl-0.45-r2.ebuild b/app-misc/mepl/mepl-0.45-r2.ebuild
new file mode 100644
index 000000000000..7a9c8a94b754
--- /dev/null
+++ b/app-misc/mepl/mepl-0.45-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Self-employed-mode software for 3COM/USR message modems"
+HOMEPAGE="https://web.archive.org/web/20031204100644/http://www.hof-berlin.de:80/mepl/"
+SRC_URI="http://www.hof-berlin.de/mepl/mepl${PV}.tar.gz"
+S="${WORKDIR}/${PN}${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-gcc433.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin mepl meplmail
+ insinto /etc
+ doins mepl.conf
+ newman mepl.en mepl.7
+}