summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch32
-rw-r--r--app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild74
2 files changed, 106 insertions, 0 deletions
diff --git a/app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch b/app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch
new file mode 100644
index 000000000000..40fff21c022c
--- /dev/null
+++ b/app-misc/pax-utils/files/pax-utils-1.2.3-python-3.7.patch
@@ -0,0 +1,32 @@
+From 2acc5c3278354f56c70f9f48e66eb0203d5e8370 Mon Sep 17 00:00:00 2001
+From: Oleksandr Natalenko <oleksandr@natalenko.name>
+Date: Sat, 17 Nov 2018 15:43:09 +0100
+Subject: [PATCH] lddtree.py: use errno properly
+
+os.errno interface is removed [1], thus should not be used. In fact, it
+is not used in other places of lddtree.py, so fix this one too, because
+it breaks --copy-to-tree on systems with Python 3.7.
+
+[1] https://bugs.python.org/issue33666
+
+Bug: https://bugs.gentoo.org/671522
+Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ lddtree.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/lddtree.py
++++ b/lddtree.py
+@@ -122,7 +122,7 @@ def makedirs(path):
+ try:
+ os.makedirs(path)
+ except OSError as e:
+- if e.errno != os.errno.EEXIST:
++ if e.errno != errno.EEXIST:
+ raise
+
+
+--
+2.19.2
+
diff --git a/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild b/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild
new file mode 100644
index 000000000000..880abaa929a9
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.2.3-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit eutils python-single-r1 toolchain-funcs unpacker
+
+DESCRIPTION="ELF utils that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps debug python seccomp"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ )
+ seccomp? ( sys-libs/libseccomp )"
+DEPEND="${RDEPEND}
+ caps? ( virtual/pkgconfig )
+ seccomp? ( virtual/pkgconfig )
+ app-arch/xz-utils"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.7.patch
+)
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_DEBUG=$(usex debug) \
+ USE_PYTHON=$(usex python) \
+ USE_SECCOMP=$(usex seccomp) \
+ "$@"
+}
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux ||
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
+ else
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+
+ use python && python_fix_shebang "${ED}"/usr/bin/lddtree
+}