summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pipeworks/pipeworks-0.4-r2.ebuild')
-rw-r--r--app-misc/pipeworks/pipeworks-0.4-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/pipeworks/pipeworks-0.4-r2.ebuild b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
new file mode 100644
index 000000000000..3094418d0f38
--- /dev/null
+++ b/app-misc/pipeworks/pipeworks-0.4-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small utility that measures throughput between stdin and stdout"
+HOMEPAGE="https://sourceforge.net/projects/pipeworks/"
+SRC_URI="mirror://sourceforge/pipeworks/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin pipeworks
+ doman pipeworks.1
+ dodoc Changelog README
+}