summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/radeontop/radeontop-1.3-r1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-misc/radeontop/radeontop-1.3-r1.ebuild b/app-misc/radeontop/radeontop-1.3-r1.ebuild
deleted file mode 100644
index c82aa5733c6a..000000000000
--- a/app-misc/radeontop/radeontop-1.3-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs
-
-DESCRIPTION="Utility to view Radeon GPU utilization"
-HOMEPAGE="https://github.com/clbr/radeontop"
-SRC_URI="https://github.com/clbr/radeontop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls video_cards_amdgpu video_cards_radeon"
-REQUIRED_USE="
- || ( video_cards_amdgpu video_cards_radeon )
-"
-
-RDEPEND="
- sys-libs/ncurses:0=
- x11-libs/libdrm[video_cards_amdgpu?,video_cards_radeon?]
- x11-libs/libpciaccess
- x11-libs/libxcb
- nls? (
- sys-libs/ncurses:0=[unicode]
- virtual/libintl
- )
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
-"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- cat > include/version.h <<-EOF || die
- #ifndef VER_H
- #define VER_H
-
- #define VERSION "${PV}"
-
- #endif
- EOF
- >getver.sh || die
- touch .git || die
-}
-
-src_configure() {
- tc-export CC
- export LIBDIR=$(get_libdir)
- export nls=$(usex nls 1 0)
- export amdgpu=1
- export xcb=1
- # Do not add -g or -s to CFLAGS
- export plain=1
-}