summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/unoconv/unoconv-0.9.0-r1.ebuild')
-rw-r--r--app-office/unoconv/unoconv-0.9.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/unoconv/unoconv-0.9.0-r1.ebuild b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..93082339a752
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+inherit python-single-r1
+
+DESCRIPTION="Convert between document formats supported by LibreOffice"
+HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog CHANGELOG.md README.adoc
+}