summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/pinpoint/Manifest1
-rw-r--r--app-office/pinpoint/pinpoint-0.1.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-office/pinpoint/Manifest b/app-office/pinpoint/Manifest
index 8a8d57ada897..bcd986fd67b5 100644
--- a/app-office/pinpoint/Manifest
+++ b/app-office/pinpoint/Manifest
@@ -1 +1,2 @@
+DIST pinpoint-0.1.6.tar.xz 773492 SHA256 812a6e49ccd8bcd6cd0927fda98ceb0f2bafb1f18246bd2d75ea96c3c971f34b SHA512 5db48b64eb69fe677b5a4c226e989ce6eaea483396de82fdd644e4c4ed238ad5fd11f956ed6ffd1badbdfa8c9d24e9ec23375572360094721135c3b6a8347c27 WHIRLPOOL de1749d53b1512e0af761ef7457f01975b90a3301bed1b9e53a267349358b849be1f04d9a74aef98b02a6ddbf200c1ecd7dbe466ed9a207f5a1659a311cb0e57
DIST pinpoint-215ccad331a39c6e95d173938fcfffe6eb4d75d6.tar.xz 708020 SHA256 1303581f09ff6414269fe0642f7ce51094ebc5cee5101ef5b3113054da0bc8e9 SHA512 efbc711e034a968b104cca669fedaae8c1f088f598996843a65849f632ebdbff3df8d36225852b24327c26e2b972b1c5097775531b23ebc3eedf62415346f27e WHIRLPOOL 1c80ee81257c42b10ab860eabd4a95c61a9980b80cfb901ce167e70cf0046586b74e3670bffdb4342adfd378fb02c97ecfb1f4ae59d3e0ce09b205f9ef1e7ebd
diff --git a/app-office/pinpoint/pinpoint-0.1.6.ebuild b/app-office/pinpoint/pinpoint-0.1.6.ebuild
new file mode 100644
index 000000000000..60a066076ce7
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://wiki.gnome.org/Apps/Pinpoint"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND="
+ >=media-libs/clutter-1.12:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( media-libs/clutter-gst:3.0 )
+ pdf? ( gnome-base/librsvg:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ gnome2_src_configure \
+ --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ gnome2_src_install
+
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+}