summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gemato/gemato-16.2.ebuild')
-rw-r--r--app-portage/gemato/gemato-16.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/app-portage/gemato/gemato-16.2.ebuild b/app-portage/gemato/gemato-16.2.ebuild
deleted file mode 100644
index 95426f14b479..000000000000
--- a/app-portage/gemato/gemato-16.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-PYTHON_REQ_USE='threads(+)'
-
-inherit distutils-r1
-
-DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-IUSE="+gpg tools"
-
-RDEPEND="
- gpg? (
- >=app-crypt/gnupg-2.2.20-r1
- dev-python/requests[${PYTHON_USEDEP}]
- )"
-BDEPEND="
- test? (
- >=app-crypt/gnupg-2.2.20-r1
- >=dev-python/pytest-5[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use tools; then
- exeinto /usr/share/gemato
- doexe utils/*.{bash,py}
- fi
-}