summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gemato/gemato-9999.ebuild')
-rw-r--r--app-portage/gemato/gemato-9999.ebuild55
1 files changed, 30 insertions, 25 deletions
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index eadfa2181db3..2930ef35cc4e 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -1,38 +1,43 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-# pyblake2 & pysha3 are broken with pypy3
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE='threads(+)'
+
inherit distutils-r1 git-r3
DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+EGIT_REPO_URI="https://github.com/projg2/gemato.git"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS=""
-IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
-
-MODULE_RDEPEND="
- blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )
- bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
- gpg? ( app-crypt/gnupg )
- lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )"
-
-RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
- test? ( ${MODULE_RDEPEND} )"
-
-python_test() {
- esetup.py test
-}
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
python_install_all() {
distutils-r1_python_install_all