summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/genlop/genlop-0.30.9-r1.ebuild')
-rw-r--r--app-portage/genlop/genlop-0.30.9-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/genlop/genlop-0.30.9-r1.ebuild b/app-portage/genlop/genlop-0.30.9-r1.ebuild
new file mode 100644
index 000000000000..1a614276a856
--- /dev/null
+++ b/app-portage/genlop/genlop-0.30.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit base bash-completion-r1
+
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl"
+SRC_URI="mirror://gentoo//${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/DateManip
+ dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+# Populate the patches array for any patches for -rX releases
+PATCHES=( "${FILESDIR}"/${P}-display.patch )
+
+src_install() {
+ dobin genlop || die "failed to install genlop (via dobin)"
+ dodoc README Changelog
+ doman genlop.1
+ newbashcomp genlop.bash-completion genlop
+}