summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gverify/gverify-2.ebuild')
-rw-r--r--app-portage/gverify/gverify-2.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/app-portage/gverify/gverify-2.ebuild b/app-portage/gverify/gverify-2.ebuild
index 98f18ec01d02..db36790e3f20 100644
--- a/app-portage/gverify/gverify-2.ebuild
+++ b/app-portage/gverify/gverify-2.ebuild
@@ -1,32 +1,39 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_COMPAT=( python3_{7,8} )
inherit python-single-r1
DESCRIPTION="gentoo.git signature verification tool"
-HOMEPAGE="https://github.com/mgorny/gverify"
-SRC_URI="https://github.com/mgorny/gverify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/projg2/gverify/"
+SRC_URI="
+ https://github.com/projg2/gverify/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
REQUIRED_USE=${PYTHON_REQUIRED_USE}
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
app-crypt/gnupg
- app-crypt/openpgp-keys-gentoo-auth
- dev-vcs/git"
-DEPEND="${PYTHON_DEPS}"
+ sec-keys/openpgp-keys-gentoo-auth
+ dev-vcs/git
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
src_compile() {
emake PREFIX="${EPREFIX}"/usr
}
src_install() {
- emake install DESTDIR="${D}" PREFIX=/usr
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}"/usr
dodoc README
}