summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/quoter/quoter-4.2.ebuild')
-rw-r--r--app-shells/quoter/quoter-4.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-shells/quoter/quoter-4.2.ebuild b/app-shells/quoter/quoter-4.2.ebuild
new file mode 100644
index 000000000000..71913b702e01
--- /dev/null
+++ b/app-shells/quoter/quoter-4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2016-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ rm -f "${ED}"/usr/bin/quoter_pipe.sh || die
+ insinto /usr/share/${PN}
+ doins bin/quoter_pipe.sh
+}