summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cedilla/cedilla-0.6.ebuild')
-rw-r--r--app-text/cedilla/cedilla-0.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/cedilla/cedilla-0.6.ebuild b/app-text/cedilla/cedilla-0.6.ebuild
new file mode 100644
index 000000000000..f9dc5040f2dd
--- /dev/null
+++ b/app-text/cedilla/cedilla-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="UTF-8 to postscript converter"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="dev-lisp/clisp"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/cedilla-gentoo-r1.patch
+}
+
+src_compile() {
+ ./compile-cedilla || die "Compile failed."
+}
+
+src_install() {
+ sed -i "s#${ED%/}##g" cedilla || die "sed failed"
+ newman cedilla.man cedilla.1
+ ./install-cedilla || die "Install failed."
+ dodoc NEWS README
+}