summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/code2html/code2html-0.9.1-r2.ebuild')
-rw-r--r--app-text/code2html/code2html-0.9.1-r2.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/app-text/code2html/code2html-0.9.1-r2.ebuild b/app-text/code2html/code2html-0.9.1-r2.ebuild
index d56c83132575..37f32dd7a3c8 100644
--- a/app-text/code2html/code2html-0.9.1-r2.ebuild
+++ b/app-text/code2html/code2html-0.9.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils prefix
+inherit prefix
DESCRIPTION="Converts source files to colored HTML output"
HOMEPAGE="http://www.palfrader.org/code2html/"
@@ -13,27 +13,30 @@ SRC_URI="http://www.palfrader.org/code2html/all/${P}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-DEPEND=""
RDEPEND=">=dev-lang/perl-5"
-src_prepare() {
+PATCHES=(
# Be consistent in color codes (bug #119406)
- epatch "${WORKDIR}"/${P}-lowercase_color_codes.patch
+ "${WORKDIR}"/${P}-lowercase_color_codes.patch
# Improved C++ support (bug #133159)
- epatch "${WORKDIR}"/${P}-cpp_keywords.patch
+ "${WORKDIR}"/${P}-cpp_keywords.patch
# Improved Ada support (bug #133176)
- epatch "${WORKDIR}"/${P}-ada_identifiers.patch
+ "${WORKDIR}"/${P}-ada_identifiers.patch
# For prefix paths
- epatch "${FILESDIR}"/${P}-prefix.patch
- eprefixify code2html
+ "${FILESDIR}"/${P}-prefix.patch
# For newer Perl, bug 523610
- epatch "${FILESDIR}"/${P}-scalar.patch
+ "${FILESDIR}"/${P}-scalar.patch
+)
+
+src_prepare() {
+ default
+
+ eprefixify code2html
}
src_install() {