summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/dictd/files/dictd-1.12.0-build.patch')
-rw-r--r--app-text/dictd/files/dictd-1.12.0-build.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-text/dictd/files/dictd-1.12.0-build.patch b/app-text/dictd/files/dictd-1.12.0-build.patch
new file mode 100644
index 000000000000..d192f8ccb961
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.12.0-build.patch
@@ -0,0 +1,22 @@
+don't force -static so we get both pic and non-pic objects
+
+https://bugs.gentoo.org/342669
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -117,12 +117,12 @@
+ @SET_MAKE@
+
+ %.o: %.c
+- $(LIBTOOL) --tag=CC --mode=compile $(CC) -c $(CFLAGS) $< -o $@
++ $(LIBTOOL) --tag=CC --mode=compile $(CC) -c $(CFLAGS) $< -o $@ -static
+ %.o: %.cpp
+- $(LIBTOOL) --tag=CXX --mode=compile $(CXX) -c $(CFLAGS) $< -o $@
++ $(LIBTOOL) --tag=CXX --mode=compile $(CXX) -c $(CFLAGS) $< -o $@ -static
+
+ %: %.o
+- $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ -static \
++ $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ \
+ $^ $(OBJS) $(LDFLAGS) -lz ${LIBS}
+
+ include $(srcdir)/deps