summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/Manifest1
-rw-r--r--app-text/dos2unix/dos2unix-6.0.6.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index b7a100a9a5f0..71d1edf8cfbe 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1,3 +1,2 @@
-DIST dos2unix-6.0.6.tar.gz 339149 SHA256 8abbd4e9a630ef649f5ff359df10786c50b302c1b6515cf99bd787adea23d276 SHA512 6affdcdc34b1f0c8b1bab46ed63af73a62abf80d64b44e951e354d05b420dbdf32a918a1bca5b427120927e1ec3fe5553cf9b7bf000de30d955ff760b6b66e45 WHIRLPOOL dbdf70a0c7dc4b5714184f333c49e438dda22f20cfc8a65ad9dcc662ccc8c01c928097a10e7932d98f398deb408d6168286b86dc550f77c6540806e3e0302d65
DIST dos2unix-7.3.1.tar.gz 552530 SHA256 f4d5df24d181c2efecf7631aab6e894489012396092cf206829f1f9a98556b94 SHA512 8bfe2ed739f5b28ceddbcd33e8a214b1cbc4b02ddab6f0528d050c411754365b6b7314a857a45cefaf13f719ad86a1fe7c18841e63f851f7f4c9e586cfa4f0fd WHIRLPOOL 5eae8985f5aeabe82230cf9451509469323a3c97e9a256bb6a31e82b77e9d2ac74c88d87147e6feeff9f088a48b9df910f900f9f952bf17809f07ee7478ce060
DIST dos2unix-7.3.tar.gz 497218 SHA256 8175f7552a72edaaa8918fdee68ce2cbc982dc25452f33d4dc611d769f4944d1 SHA512 dc70fc4cf12811794e9b33db7cc44085788450104f7beefacea5ac11af5ca76d909235232be51eb7a32ed5d75a01a86a4c6b064060b945c8a7e7968caeb51cea WHIRLPOOL 55b3990816a122c4bc2219b1f89b5d7f619901693b57349b58222166f5c3e006db08a55a26ce62493009459b9a3c6a091a07ecacabf9450a0a7475fbd9f195ae
diff --git a/app-text/dos2unix/dos2unix-6.0.6.ebuild b/app-text/dos2unix/dos2unix-6.0.6.ebuild
deleted file mode 100644
index b1c772174d04..000000000000
--- a/app-text/dos2unix/dos2unix-6.0.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
-HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
-SRC_URI="
- http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
- mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="debug nls"
-
-RDEPEND="
- !app-text/hd2u
- !app-text/unix2dos
- virtual/libintl"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
- dev-lang/perl"
-
-src_prepare() {
- sed \
- -e '/^LDFLAGS/s|=|+=|' \
- -e '/CFLAGS_OS \+=/d' \
- -e '/LDFLAGS_EXTRA \+=/d' \
- -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
- -i Makefile || die
-
- if use debug ; then
- sed -e "/^DEBUG/s:0:1:" \
- -e "/EXTRA_CFLAGS +=/s:-g::" \
- -i Makefile || die
- fi
-
- tc-export CC
-}
-
-lintl() {
- # same logic as from virtual/libintl
- use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
-}
-
-src_compile() {
- emake prefix="${EPREFIX}/usr" \
- $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
-}
-
-src_install() {
- emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
- $(usex nls "" "ENABLE_NLS=") install
-}