summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/dvisvgm/dvisvgm-2.0.4.ebuild')
-rw-r--r--app-text/dvisvgm/dvisvgm-2.0.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-text/dvisvgm/dvisvgm-2.0.4.ebuild b/app-text/dvisvgm/dvisvgm-2.0.4.ebuild
deleted file mode 100644
index 0e56364dbf9c..000000000000
--- a/app-text/dvisvgm/dvisvgm-2.0.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs flag-o-matic autotools
-
-DESCRIPTION="Converts DVI files to SVG"
-HOMEPAGE="http://dvisvgm.bplaced.net/"
-SRC_URI="https://github.com/mgieseki/dvisvgm/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-# Tests don't work from $WORKDIR: kpathsea tries to search in relative
-# directories from where the binary is executed.
-# We cannot really use absolute paths in the kpathsea configuration since that
-# would make it harder for prefix installs.
-RESTRICT="test"
-
-RDEPEND="virtual/tex-base
- app-text/ghostscript-gpl
- >=media-gfx/potrace-1.10-r1
- media-libs/freetype:2
- dev-libs/kpathsea
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- app-text/xmlto
- app-text/asciidoc
- virtual/pkgconfig
- test? ( dev-cpp/gtest )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-c99-compile.patch
- eautoreconf
-}
-
-src_configure() {
- has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
- default
-}