summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/hunspell')
-rw-r--r--app-text/hunspell/Manifest1
-rw-r--r--app-text/hunspell/files/hunspell-1.5.0-renameexes.patch124
-rw-r--r--app-text/hunspell/hunspell-1.5.0.ebuild84
3 files changed, 209 insertions, 0 deletions
diff --git a/app-text/hunspell/Manifest b/app-text/hunspell/Manifest
index 80c8229ada71..07f23ad8e89d 100644
--- a/app-text/hunspell/Manifest
+++ b/app-text/hunspell/Manifest
@@ -2,3 +2,4 @@ DIST hunspell-1.3.3.tar.gz 986081 SHA256 a7b2c0de0e2ce17426821dc1ac8eb115029959b
DIST hunspell-1.3.4.tar.gz 1004935 SHA256 55918522cb0041748507dd4f5aa92d043cef337aa589b9367c2221da084281ac SHA512 092818570f5eb152b2bf8d0964068510185304f41e1eb0946bf7589c640d21bff67d2b79b49f770e8c0baa9031ab449eefb9e3b0bce8a28e2fc4809007fefa99 WHIRLPOOL 0e7c1941d31824e3a8f93200b6b228f56b0e35f14498a138425b177bc5a47274d422cd7b1d4836ebdb74b449bf777129381382e7b66211f5e8d1507cc3becdf7
DIST hunspell-1.4.1.tar.gz 1000647 SHA256 c4476aff0ced52eec334eae1e8d3fdaaebdd90f5ecd0b57cf2a92a6fd220d1bb SHA512 6edc1120a08d46f1c3a590f9964486240eee46ef7f1c2d072c228d26dd1cb3bee1f283d007fcda994cdf0482c065cd5375c9706570a7c5be9aff423e19c03b6b WHIRLPOOL 7f250ba58369ca12282bf23d85396e66385197d3d1d268e3bae39d197029438543ba9377abe224a9b2dea860fe816c627e10adf27f1d2198793a18ded95534cf
DIST hunspell-1.4.2.tar.gz 1000676 SHA256 b6a0b23d083e0130f8c561cca8c980814ba65740ccfa52f47159f9141089946d SHA512 b4528e9cc926456809b6a0c0c95ed95b297ca564c219bb229f8daefcc7aa4d50e77c99778f8eba867106d284a6ed6320e6966a7b304c7af873908cf55118f8f3 WHIRLPOOL 0343c7e507c6eae0d9df38a3c9bcf1ec847c3afc5497ac9dd729df1418cb0a398d25ee47da8fe498230ef7589d6735abb6a5eee6f2d5125e418437eaa9500ddc
+DIST hunspell-1.5.0.tar.gz 1110566 SHA256 651ef922c1638644cf4e7fb1180f9b1345b3a26322dc2a22af9df083da9b9dae SHA512 a9b24fe9d1813879bcd00ee833d1c36656d2e97e3bff68dc47da6da014d52d8af64b8169ec8ca026688b4dcd12553c9c2a1fc08fdd9c22851983d574e4f6ebe0 WHIRLPOOL a2ea200f6ec8a2d935e418aceae503998055a512364d3cb66d26fd4382baaa62e6ede05a6da9b348503dbc45745c5368698770144dbe3fa79e93f2c8ecf1be57
diff --git a/app-text/hunspell/files/hunspell-1.5.0-renameexes.patch b/app-text/hunspell/files/hunspell-1.5.0-renameexes.patch
new file mode 100644
index 000000000000..f2a555e34065
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.5.0-renameexes.patch
@@ -0,0 +1,124 @@
+--- hunspell-1.5.0/src/tools/chmorph.cxx
++++ hunspell-1.5.0/src/tools/chmorph.cxx
+@@ -58,11 +58,11 @@
+ if (!argv[i]) {
+ fprintf(
+ stderr,
+- "chmorph - change affixes by morphological analysis and generation\n"
+- "correct syntax is:\nchmorph affix_file "
++ "hunspell-chmorph - change affixes by morphological analysis and generation\n"
++ "correct syntax is:\nhunspell-chmorph affix_file "
+ "dictionary_file file_to_convert STRING1 STRING2\n"
+ "STRINGS may be arbitrary parts of the morphological descriptions\n"
+- "example: chmorph hu.aff hu.dic hu.txt SG_2 SG_3 "
++ "example: hunspell-chmorph hu.aff hu.dic hu.txt SG_2 SG_3 "
+ " (convert informal Hungarian second person texts to formal third "
+ "person texts)\n");
+ exit(1);
+--- hunspell-1.5.0/src/tools/example.cxx
++++ hunspell-1.5.0/src/tools/example.cxx
+@@ -53,9 +53,9 @@
+ /* first parse the command line options */
+
+ if (argc < 4) {
+- fprintf(stderr, "example (now it works with more dictionary files):\n");
++ fprintf(stderr, "hunspell-example (now it works with more dictionary files):\n");
+ fprintf(stderr,
+- "example affix_file dictionary_file(s) file_of_words_to_check\n");
++ "hunspell-example affix_file dictionary_file(s) file_of_words_to_check\n");
+ exit(1);
+ }
+
+--- hunspell-1.5.0/src/tools/Makefile.am
++++ hunspell-1.5.0/src/tools/Makefile.am
+@@ -1,4 +1,4 @@
+-bin_PROGRAMS=analyze chmorph hunspell munch unmunch hzip hunzip
++bin_PROGRAMS=hunspell-analyze hunspell-chmorph hunspell hunspell-munch hunspell-unmunch hzip hunzip
+
+ INCLUDES=-I${top_builddir}/src/hunspell -I${top_srcdir}/src/hunspell -I${top_srcdir}/src/parsers
+
+@@ -6,8 +6,8 @@
+ hunzip_SOURCES=hunzip.cxx
+ hunzip_LDADD = ../hunspell/libhunspell-1.5.la
+
+-munch_SOURCES=munch.cxx munch.h
+-unmunch_SOURCES=unmunch.cxx unmunch.h
++hunspell_munch_SOURCES=munch.cxx munch.h
++hunspell_unmunch_SOURCES=unmunch.cxx unmunch.h
+
+ example_SOURCES=example.cxx
+ example_LDADD = ../hunspell/libhunspell-1.5.la
+@@ -16,11 +16,11 @@
+ hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
+ ../hunspell/libhunspell-1.5.la @CURSESLIB@ @READLINELIB@
+
+-analyze_SOURCES=analyze.cxx
+-analyze_LDADD = ../hunspell/libhunspell-1.5.la
++hunspell_analyze_SOURCES=analyze.cxx
++hunspell_analyze_LDADD = ../hunspell/libhunspell-1.5.la
+
+-chmorph_SOURCES=chmorph.cxx
+-chmorph_LDADD = ../parsers/libparsers.a ../hunspell/libhunspell-1.5.la
++hunspell_chmorph_SOURCES=chmorph.cxx
++hunspell_chmorph_LDADD = ../parsers/libparsers.a ../hunspell/libhunspell-1.5.la
+
+ noinst_PROGRAMS=example
+
+--- hunspell-1.5.0/src/tools/munch.cxx
++++ hunspell-1.5.0/src/tools/munch.cxx
+@@ -81,14 +81,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr, "correct syntax is:\n");
+- fprintf(stderr, "munch word_list_file affix_file\n");
++ fprintf(stderr, "hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr, "correct syntax is:\n");
+- fprintf(stderr, "munch word_list_file affix_file\n");
++ fprintf(stderr, "hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+
+--- hunspell-1.5.0/src/tools/unmunch.cxx
++++ hunspell-1.5.0/src/tools/unmunch.cxx
+@@ -76,14 +76,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr, "correct syntax is:\n");
+- fprintf(stderr, "unmunch dic_file affix_file\n");
++ fprintf(stderr, "hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr, "correct syntax is:\n");
+- fprintf(stderr, "unmunch dic_file affix_file\n");
++ fprintf(stderr, "hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+
+--- hunspell-1.5.0/tests/test.sh
++++ hunspell-1.5.0/tests/test.sh
+@@ -74,7 +74,7 @@
+ shopt -s expand_aliases
+
+ alias hunspell='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell'
+-alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/analyze'
++alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell-analyze'
+
+ if [ "$VALGRIND" != "" ]; then
+ rm -f $TEMPDIR/test.pid*
+@@ -83,7 +83,7 @@
+ fi
+
+ alias hunspell='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/hunspell'
+- alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/analyze'
++ alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/hunspell-analyze'
+ fi
+
+ # Tests good words
diff --git a/app-text/hunspell/hunspell-1.5.0.ebuild b/app-text/hunspell/hunspell-1.5.0.ebuild
new file mode 100644
index 000000000000..f81062ce3f24
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.5.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils multilib autotools flag-o-matic versionator
+
+MY_P=${PN}-${PV/_beta/b}
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+
+SLOT="0/$(get_version_component_range 1-2)"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses nls readline static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ ncurses? ( sys-libs/ncurses:0= )
+ readline? ( sys-libs/readline:= )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+LANGS="af bg ca cs cy da de de-1901 el en eo es et fo fr ga gl he hr hu ia id
+is it km ku lt lv mi mk ms nb nl nn pl pt pt-BR ro ru sk sl sq sv sw tn uk zu"
+
+PDEPEND="app-dicts/myspell-en"
+for lang in ${LANGS}; do
+ IUSE+=" l10n_${lang}"
+ case ${lang} in
+ de-1901) dict="de_1901" ;;
+ pt-BR) dict="pt-br" ;;
+ *) dict="${lang}" ;;
+ esac
+ PDEPEND+=" l10n_${lang}? ( app-dicts/myspell-${dict} )"
+done
+unset dict lang LANGS
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ AUTHORS ChangeLog NEWS README THANKS TODO license.hunspell
+ AUTHORS.myspell README.myspell license.myspell
+)
+
+PATCHES=(
+ # Upstream package creates some executables which names are too generic
+ # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence eautoreconf.
+ "${FILESDIR}/${PN}-1.5.0-renameexes.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # missing somehow, and I am too lazy to fix it properly
+ [[ ${CHOST} == *-darwin* ]] && append-libs -liconv
+
+ # I wanted to put the include files in /usr/include/hunspell.
+ # You can do that, libreoffice can find them anywhere, just
+ # ping me when you do so ; -- scarabeus
+ econf \
+ $(use_enable nls) \
+ $(use_with ncurses ui) \
+ $(use_with readline readline) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ einstalldocs
+
+ prune_libtool_files --all
+
+ #342449
+ pushd "${ED}"/usr/$(get_libdir)/ >/dev/null
+ ln -s lib${PN}{-$(get_major_version).$(get_version_component_range 2).so.0.0.0,.so}
+ popd >/dev/null
+}