summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mupdf/files')
-rw-r--r--app-text/mupdf/files/mupdf-1.11-drop-libmupdfthird.patch11
-rw-r--r--app-text/mupdf/files/mupdf-1.12-CFLAGS.patch11
2 files changed, 22 insertions, 0 deletions
diff --git a/app-text/mupdf/files/mupdf-1.11-drop-libmupdfthird.patch b/app-text/mupdf/files/mupdf-1.11-drop-libmupdfthird.patch
index eaf116788682..e5600c00cd83 100644
--- a/app-text/mupdf/files/mupdf-1.11-drop-libmupdfthird.patch
+++ b/app-text/mupdf/files/mupdf-1.11-drop-libmupdfthird.patch
@@ -9,3 +9,14 @@
THREAD_LIB = $(OUT)/libmuthreads.a
MUPDF_OBJ := $(FITZ_OBJ) $(FONT_OBJ) $(PDF_OBJ) $(XPS_OBJ) $(SVG_OBJ) $(CBZ_OBJ) $(HTML_OBJ) $(GPRF_OBJ)
+--- mupdf-1.12.0-source/Makefile
++++ mupdf-1.12.0-source/Makefile
+@@ -343,7 +343,7 @@
+
+ THREAD_OBJ := $(THREAD_OBJ)
+
+-$(MUPDF_LIB) : $(MUPDF_OBJ)
++$(MUPDF_LIB) : $(MUPDF_OBJ) $(THIRD_OBJ)
+ $(THIRD_LIB) : $(THIRD_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+
diff --git a/app-text/mupdf/files/mupdf-1.12-CFLAGS.patch b/app-text/mupdf/files/mupdf-1.12-CFLAGS.patch
new file mode 100644
index 000000000000..796d127263ae
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.12-CFLAGS.patch
@@ -0,0 +1,11 @@
+--- mupdf-1.12.0-source/Makerules
++++ mupdf-1.12.0-source/Makerules
+@@ -22,8 +22,6 @@
+ endif
+
+ ifeq "$(build)" "debug"
+-CFLAGS += -pipe -g
+-LDFLAGS += -g
+ else ifeq "$(build)" "release"
+ CFLAGS += -pipe -O2 -DNDEBUG -fomit-frame-pointer
+ LDFLAGS += $(LDREMOVEUNREACH) -Wl,-s