summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index b66438cbc496..1bd73b2a7914 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -2,3 +2,4 @@ DIST xapian-omega-1.2.22.tar.xz 437556 SHA256 a7d4b00f6830d003490c0f727fc03584e7
DIST xapian-omega-1.2.24.tar.xz 438104 SHA256 45fca431b812ddacbd592b522389474317af386b3ab554908edd36fc5918da53 SHA512 df483ed1410ca04df3b1ec4248442c91b03bd407737d022e494ffe3e14d62a41ee73b27114a979f59825e0ea2f2d16e0eea3c518a8db0094d697f0093e21f6a7 WHIRLPOOL af7a01659a48cf63a63dfe231cd39bc9d1dabb4e3e097262d21b73d3b99145ba3fe348c3126103dc3c91f4b9a2a1a61c1a4a80b0a0830580bcdf1b5a0cd8c393
DIST xapian-omega-1.2.25.tar.xz 440224 SHA256 041ada3c22d5a5f1c10fd3681426377696924def75ea6cb6710a182016bc7482 SHA512 f412538cd50c82d7af28f2620c1e377afd3f03186259a145f9a37cd64d05837b7cc6f205627a3c8e4c25ec19efc2a81a6fe3a415d00b7a6f4df847d6ff2d453c WHIRLPOOL 2fbbcad9807e15013b2c570ca12d6b70bca9b13ceda234be92a149e71f329ea4062a0842f0be889395cca5f9e082031b9ad05460dae6ef45343243e0e159c011
DIST xapian-omega-1.4.4.tar.xz 501712 SHA256 14dd790b94b828b457120439886bb5de59ccb5d7a8cefcdcf47daba5817e895e SHA512 927c6afe24f8a13018fcc233e874c71c0912cb6200094f7246c12b4175bc48d752312e57128a314e7674a948a50ef092dd7f2dc8910db7df8f3ccf9c44f38533 WHIRLPOOL ef061913e5997bab155979e75ffe3ada19384f58e2c75c8cd5957bfae0eada5b8f110b79f63e45b28499222395500d923828c43e3890e11bc248689e43d8ae85
+DIST xapian-omega-1.4.5.tar.xz 502820 SHA256 99c93ca908509daebbaa5c17486878810364e6a623c7c5856fbd40722743517e SHA512 895da1e1a3ddf2e5e8576fd41853cc5cb7c6e4f0223a0d25f6303fd01ca26f64c8e41616d6d66b2309a4ca5763b2b20b208dbf6054f0498411f2678422c07893 WHIRLPOOL 9577870aa3d0f0ad79a65520d4183c726ce8256a7c334f4bdb7c564e2d6bd4fc8ccfe78dbd05d3e484f4224ce7dce5cb7b7715c5f98584ef10e03da4d357f427
diff --git a/app-text/xapian-omega/xapian-omega-1.4.5.ebuild b/app-text/xapian-omega/xapian-omega-1.4.5.ebuild
new file mode 100644
index 000000000000..36899fc06ac8
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="http://www.xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/xapian:0/30
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}