summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-ps/zathura-ps-0.2.3.ebuild')
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/zathura-ps/zathura-ps-0.2.3.ebuild b/app-text/zathura-ps/zathura-ps-0.2.3.ebuild
new file mode 100644
index 000000000000..6184d6f8bdb1
--- /dev/null
+++ b/app-text/zathura-ps/zathura-ps-0.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="PostScript plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+else
+KEYWORDS=""
+fi
+IUSE=""
+
+RDEPEND=">=app-text/libspectre-0.2.6:=
+ >=app-text/zathura-0.2.7
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}/usr"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}