summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/metadata.xml14
-rw-r--r--app-text/nuspell/nuspell-3.0.0.ebuild32
3 files changed, 47 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
new file mode 100644
index 000000000000..79e246255bee
--- /dev/null
+++ b/app-text/nuspell/Manifest
@@ -0,0 +1 @@
+DIST nuspell-3.0.0.tar.gz 403043 BLAKE2B b437012e4fb327f13d9ff0944dadf7e865c670daf153be00dd48e9d2fc01c87d410ebd5aeaa094f6446d3035346738010cdba961cfaada3751bedce264beaa6a SHA512 d9cd7dd276e2bca43dec3abaf11c5206695949b9fda8c9b86f2772cc7e8fa95bf17c685a2ef9ca87fe3c4f0b55f2fcb435bc21c187355f5e3fa35dcafab2c8c2
diff --git a/app-text/nuspell/metadata.xml b/app-text/nuspell/metadata.xml
new file mode 100644
index 000000000000..6a10d096c251
--- /dev/null
+++ b/app-text/nuspell/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription>
+ Spell checker library and command-line program designed for
+ languages with rich morphology and complex word compounding.
+
+ Nuspell is a pure C++ re-implementation of <pkg>app-text/hunspell</pkg>.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-text/nuspell/nuspell-3.0.0.ebuild b/app-text/nuspell/nuspell-3.0.0.ebuild
new file mode 100644
index 000000000000..efd1c51aa487
--- /dev/null
+++ b/app-text/nuspell/nuspell-3.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/3" # due to libnuspell.so.3
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/ronn )
+ >=dev-libs/boost-1.62[icu]"
+
+DOCS=( CHANGELOG.md )
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users . Good luck!'
+ einfo
+}