summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gtranslator/Manifest1
-rw-r--r--app-text/gtranslator/gtranslator-3.32.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/gtranslator/Manifest b/app-text/gtranslator/Manifest
index 45a03b613da5..cc4db131cdae 100644
--- a/app-text/gtranslator/Manifest
+++ b/app-text/gtranslator/Manifest
@@ -1,2 +1,3 @@
DIST gtranslator-2.91.7.tar.xz 2835836 BLAKE2B e6e1f7b512705152a520a47bdddd01336ddcecb9ca20409546d64caa124f1bca2985fd2a9cd7564983a8411c6a7227d37b55ce8b3e452ee7a0d5beba3460bd59 SHA512 8d2a582e06ab0fecb9c18bde372ca0cd02d426155d4b30b876bd8f2e177c88c79d410adb0297ab85f18a952eeef32c17352cde18eda3c4c4fe33833db25022b5
DIST gtranslator-3.30.1.tar.xz 3060168 BLAKE2B e2e238ffc461b99be9df679c431d7cae85c70ca9db7aea4e7c51d9bd12aa417fab0d53d6c512555992dfb2d40f55d6d0dba8c3aacd043ad8c2ebe690de8ac562 SHA512 5f6384bec8bb23afa9aefe5928260b7ccb408d41b8a363d85277435428ca34fe544068526b11801e534911753c95b3049892e647938bee755b37f3f5cbf94f41
+DIST gtranslator-3.32.0.tar.xz 2767988 BLAKE2B cf05561d35adaa77e1bb15adb11faad5346a236d6bf82ccc2b474c2478ea537c89852e0c0322067de1bb24c320ad6732eff5a0f6489a97e57c980b0f1c7d56f6 SHA512 4119b64f671ccb4d8132c4b18f53b614a80c6faaecef212b23268b2a189e7b337dd63f9c0d82e139976a6d5615c4c047ad3be97397734930b5c0d07b57e13531
diff --git a/app-text/gtranslator/gtranslator-3.32.0.ebuild b/app-text/gtranslator/gtranslator-3.32.0.ebuild
new file mode 100644
index 000000000000..d1525621203b
--- /dev/null
+++ b/app-text/gtranslator/gtranslator-3.32.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME Translation Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gtranslator"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.36.0:2
+ >=x11-libs/gtk+-3.22.20:3
+ gnome-extra/libgda:5=
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/gspell-1.2.0:=
+ >=x11-libs/gtksourceview-4.0.2:4
+ >=dev-libs/libxml2-2.4.12:2
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# gtk-doc? ( >=dev-util/gtk-doc-1.28 )
+
+src_configure() {
+ # Needs gtk-doc we don't have at the time of gtranslator-3.32.0 introduction
+ #local emesonargs=(
+ # $(meson_use gtk-doc gtk_doc)
+ #)
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}