summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kbibtex/kbibtex-0.9.1.ebuild2
-rw-r--r--app-text/poppler/poppler-0.82.0.ebuild10
-rw-r--r--app-text/poppler/poppler-0.83.0.ebuild10
-rw-r--r--app-text/poppler/poppler-0.84.0.ebuild10
-rw-r--r--app-text/poppler/poppler-9999.ebuild10
5 files changed, 21 insertions, 21 deletions
diff --git a/app-text/kbibtex/kbibtex-0.9.1.ebuild b/app-text/kbibtex/kbibtex-0.9.1.ebuild
index e01569d3b7fd..2f8ac5f786ca 100644
--- a/app-text/kbibtex/kbibtex-0.9.1.ebuild
+++ b/app-text/kbibtex/kbibtex-0.9.1.ebuild
@@ -68,7 +68,7 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebKitWidgets=ON
$(cmake_use_find_package webengine Qt5WebEngineWidgets)
- $(cmake-utils_use_find_package zotero Qca-qt5)
+ $(cmake_use_find_package zotero Qca-qt5)
)
ecm_src_configure
diff --git a/app-text/poppler/poppler-0.82.0.ebuild b/app-text/poppler/poppler-0.82.0.ebuild
index 8386256fc10c..1ad433185f4c 100644
--- a/app-text/poppler/poppler-0.82.0.ebuild
+++ b/app-text/poppler/poppler-0.82.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils toolchain-funcs xdg-utils
+inherit cmake toolchain-funcs xdg-utils
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
@@ -65,7 +65,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Clang doesn't grok this flag, the configure nicely tests that, but
# cmake just uses it, so remove it if we use clang
@@ -101,17 +101,17 @@ src_configure() {
-DENABLE_CMS=$(usex lcms lcms2 none)
-DWITH_NSS3=$(usex nss)
-DWITH_PNG=$(usex png)
- $(cmake-utils_use_find_package qt5 Qt5Core)
+ $(cmake_use_find_package qt5 Qt5Core)
-DWITH_TIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
)
use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# live version doesn't provide html documentation
if use cairo && use doc && [[ ${PV} != *9999* ]]; then
diff --git a/app-text/poppler/poppler-0.83.0.ebuild b/app-text/poppler/poppler-0.83.0.ebuild
index 33ffc42f9cac..4e79ad3d70dc 100644
--- a/app-text/poppler/poppler-0.83.0.ebuild
+++ b/app-text/poppler/poppler-0.83.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils toolchain-funcs xdg-utils
+inherit cmake toolchain-funcs xdg-utils
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
@@ -65,7 +65,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Clang doesn't grok this flag, the configure nicely tests that, but
# cmake just uses it, so remove it if we use clang
@@ -101,17 +101,17 @@ src_configure() {
-DENABLE_CMS=$(usex lcms lcms2 none)
-DWITH_NSS3=$(usex nss)
-DWITH_PNG=$(usex png)
- $(cmake-utils_use_find_package qt5 Qt5Core)
+ $(cmake_use_find_package qt5 Qt5Core)
-DWITH_TIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
)
use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# live version doesn't provide html documentation
if use cairo && use doc && [[ ${PV} != *9999* ]]; then
diff --git a/app-text/poppler/poppler-0.84.0.ebuild b/app-text/poppler/poppler-0.84.0.ebuild
index 12fe62839eb5..dc4ab8ebb00d 100644
--- a/app-text/poppler/poppler-0.84.0.ebuild
+++ b/app-text/poppler/poppler-0.84.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils toolchain-funcs xdg-utils
+inherit cmake toolchain-funcs xdg-utils
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
@@ -65,7 +65,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Clang doesn't grok this flag, the configure nicely tests that, but
# cmake just uses it, so remove it if we use clang
@@ -101,17 +101,17 @@ src_configure() {
-DENABLE_CMS=$(usex lcms lcms2 none)
-DWITH_NSS3=$(usex nss)
-DWITH_PNG=$(usex png)
- $(cmake-utils_use_find_package qt5 Qt5Core)
+ $(cmake_use_find_package qt5 Qt5Core)
-DWITH_TIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
)
use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# live version doesn't provide html documentation
if use cairo && use doc && [[ ${PV} != *9999* ]]; then
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 12fe62839eb5..dc4ab8ebb00d 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils toolchain-funcs xdg-utils
+inherit cmake toolchain-funcs xdg-utils
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
@@ -65,7 +65,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Clang doesn't grok this flag, the configure nicely tests that, but
# cmake just uses it, so remove it if we use clang
@@ -101,17 +101,17 @@ src_configure() {
-DENABLE_CMS=$(usex lcms lcms2 none)
-DWITH_NSS3=$(usex nss)
-DWITH_PNG=$(usex png)
- $(cmake-utils_use_find_package qt5 Qt5Core)
+ $(cmake_use_find_package qt5 Qt5Core)
-DWITH_TIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
)
use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# live version doesn't provide html documentation
if use cairo && use doc && [[ ${PV} != *9999* ]]; then