summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/c-support')
-rw-r--r--app-vim/c-support/Manifest3
-rw-r--r--app-vim/c-support/c-support-6.0.ebuild22
-rw-r--r--app-vim/c-support/c-support-6.1.1.ebuild21
-rw-r--r--app-vim/c-support/c-support-6.1.ebuild21
-rw-r--r--app-vim/c-support/metadata.xml5
5 files changed, 72 insertions, 0 deletions
diff --git a/app-vim/c-support/Manifest b/app-vim/c-support/Manifest
new file mode 100644
index 000000000000..4a10d983e314
--- /dev/null
+++ b/app-vim/c-support/Manifest
@@ -0,0 +1,3 @@
+DIST c-support-6.0.tar.bz2 130832 SHA256 8dfb9c283967906f3a1c6d251a7d4734b58debc6da6ed4fdb0788c526492ed72 SHA512 280e8e91b8961ad856524f1869ecd580870ccbb6064c02aefdd5cec7f55a7bf12a17c76a4de91c8d2a7fed25bd96e793909f7cc258b9664f295e1324e0b392da WHIRLPOOL 5743eec9901453007a65d056cfa061f23d6f4326338071ec38748590202d81988b4699c3329d58f94334434f4506ba34b87273618e806efa2484b8ec93e83b08
+DIST c-support-6.1.1.tar.bz2 167371 SHA256 fdb8fe02383f2e998b2549194bbb6d0cb0a13d3141ca0c4d8d422b6117e83c86 SHA512 dda33732505341bc260b9c3f73f95c70c3ee6f0eb50b9d1fd534fc8e83fb21d0caa3feea0ae50cf59da4abbef455c31fe1c02c80bb9168423cfa332941ff0886 WHIRLPOOL 3a409cd378eac9e29b8e5c2fc7d9f95bacdf1dcb3c7a860e2e0c9af8fa29c1ec42129e0916ecbcd158cfb1d5bc3d0c72c423d2f661120ac860baa74f1047e5ac
+DIST c-support-6.1.tar.bz2 164255 SHA256 00cf3d664e6414f332535acd769ffadfcb68c4c1c5a85aba8ce5b8124e97dd72 SHA512 6fdc4f757ba0febfebe0c8898b6b0d582e03d6f7d08523e8663368011c41d6444df2620f96c6276d959b4a05b7c83a0e377bc5a8e75aaed5cf478f8bc83ce9ec WHIRLPOOL 01f2f5cf934882eb4c57a363e4cdaa2b7f43494cb6fb4324dcd2f679ad5e0a31698dc13b46a7f5ba5287cadce68fadb4258f6dad7ba051f9a62247d599d73150
diff --git a/app-vim/c-support/c-support-6.0.ebuild b/app-vim/c-support/c-support-6.0.ebuild
new file mode 100644
index 000000000000..b28497dd1731
--- /dev/null
+++ b/app-vim/c-support/c-support-6.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++-IDE -- Write and run programs using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=213"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,c-hotkeys.pdf}
+ rm -r ${PN}/doc || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/c-support/c-support-6.1.1.ebuild b/app-vim/c-support/c-support-6.1.1.ebuild
new file mode 100644
index 000000000000..8dc26b93a55d
--- /dev/null
+++ b/app-vim/c-support/c-support-6.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++-IDE -- Write and run programs using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=213"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,c-hotkeys.pdf}
+ rm -r ${PN}/doc || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/c-support/c-support-6.1.ebuild b/app-vim/c-support/c-support-6.1.ebuild
new file mode 100644
index 000000000000..8393982936f5
--- /dev/null
+++ b/app-vim/c-support/c-support-6.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++-IDE -- Write and run programs using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=213"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,c-hotkeys.pdf}
+ rm -r ${PN}/doc || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/c-support/metadata.xml b/app-vim/c-support/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/c-support/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>