summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/cctree')
-rw-r--r--app-vim/cctree/Manifest2
-rw-r--r--app-vim/cctree/cctree-1.60.ebuild36
-rw-r--r--app-vim/cctree/cctree-1.61.ebuild27
-rw-r--r--app-vim/cctree/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/app-vim/cctree/Manifest b/app-vim/cctree/Manifest
new file mode 100644
index 000000000000..a91918955df0
--- /dev/null
+++ b/app-vim/cctree/Manifest
@@ -0,0 +1,2 @@
+DIST cctree-1.60.tar.gz 26501 SHA256 eaf0a5799764ea8da6cf7d66c398ad5c9ebe2419cbf730c3bbc24e50682f90af SHA512 f717c912ffce3b6f6edc4e6dceae7f53ee765b88366f1040e37d2f8f7e477880baf8be8388dcc3c67b1b27766dfd1f13bae2effbbbe9dcdbc18ec4807890eadf WHIRLPOOL db3173fe99edc04cb7b47fe8b642ba2c6e43c307c9011fb6d82e0124cc1eb8d4ad18cff7990f13e276debabe2983369357fd6ff1822541c1e54f3ea6a113f373
+DIST cctree-1.61.tar.bz2 23243 SHA256 b5651bd274c6c7c126c0a5a20579cfd953d1fee1f98989a43baa4e1350e68765 SHA512 9d29c573ef3cdcde1ec91ca34684c84c8beb3b89669654b1f9dafab928a11d8f1df77294af06c7612ba8aa7d65dfba69352f3f74dd11c98d22a300907d8a6b0e WHIRLPOOL 6dd6fc055644d4bc963c2d8adca45cd24f71c319deab6a868e0b542f5076195a99ea0c400593d1bad2f64f50f7b7efbe0ba32bfff166a069dedaf7f50676b3db
diff --git a/app-vim/cctree/cctree-1.60.ebuild b/app-vim/cctree/cctree-1.60.ebuild
new file mode 100644
index 000000000000..9543b7bf5d6f
--- /dev/null
+++ b/app-vim/cctree/cctree-1.60.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="CCTree"
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="http://sites.google.com/site/vimcctree/"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="cctree.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/cctree.vim > doc/cctree.txt
+
+ rm README
+}
diff --git a/app-vim/cctree/cctree-1.61.ebuild b/app-vim/cctree/cctree-1.61.ebuild
new file mode 100644
index 000000000000..111d18abb2b3
--- /dev/null
+++ b/app-vim/cctree/cctree-1.61.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="http://sites.google.com/site/vimcctree/"
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/${PN}.vim > doc/${PN}.txt
+}
diff --git a/app-vim/cctree/metadata.xml b/app-vim/cctree/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/cctree/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>