summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/gitv/gitv-1.3.1.ebuild')
-rw-r--r--app-vim/gitv/gitv-1.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/gitv/gitv-1.3.1.ebuild b/app-vim/gitv/gitv-1.3.1.ebuild
new file mode 100644
index 000000000000..a772cbef62f2
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gregsexton/gitv.git"
+else
+ SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags addon-info.json roadmap.md || die
+ rm -r img || die
+ default
+}