summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/locateopen/locateopen-1.3.ebuild')
-rw-r--r--app-vim/locateopen/locateopen-1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/locateopen/locateopen-1.3.ebuild b/app-vim/locateopen/locateopen-1.3.ebuild
new file mode 100644
index 000000000000..5c4b4d04af5d
--- /dev/null
+++ b/app-vim/locateopen/locateopen-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open a file without supplying a path"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=858"
+
+LICENSE="vim"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} sys-apps/mlocate"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides commands that hook vim into mlocate:
+\ :LocateEdit filename
+\ :LocateSplit filename
+\ :LocateSource filename
+\ :LocateRead filename
+To configure:
+\ :let g:locateopen_ignorecase = 1 \" enable ignore case mode
+\ :let g:locateopen_smartcase = 0 \" disable smart case mode
+\ :let g:locateopen_alwaysprompt = 1 \" show menu for one match"