summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/tcomment')
-rw-r--r--app-vim/tcomment/Manifest1
-rw-r--r--app-vim/tcomment/tcomment-3.08.1.ebuild28
-rw-r--r--app-vim/tcomment/tcomment-9999.ebuild28
3 files changed, 57 insertions, 0 deletions
diff --git a/app-vim/tcomment/Manifest b/app-vim/tcomment/Manifest
index 093f2283a4c0..af1ae0480c8d 100644
--- a/app-vim/tcomment/Manifest
+++ b/app-vim/tcomment/Manifest
@@ -1 +1,2 @@
+DIST tcomment-3.08.1.tar.gz 49918 SHA256 4f42ca89bb66110fcd770862a129b225c6b54b3f8e9419dba168002de238ad6d SHA512 609d5eb1e7785fb1af829000ab27ab63ac2bb7550bcd0f91c7c35f0a8c4b879e5348745f57b11d1e24d37920056ca55da8863e15e40d6fe289617d5d898a4177 WHIRLPOOL eb4383350708e78fb6b816aca97e178897f9710a3ff4cba8dfe5c7861b65ed4b86a7532375ebdc9ff0a2635a6493788d3caeac85a079c2674c2980b8cdda3404
DIST tcomment-3.08.tar.gz 38317 SHA256 4e88509c10dbbb6fdbdf93955c004fa3d44c10536a63e1c3e4348e65454e7256 SHA512 9cb582e4c82334a5752f2a0b5b3e753fc7a4bfd3db76dd8f1ca49938f3f9890b8723476a0c3400f60ff8b358d52bf32fa8497c7b1c6118afd21bb860b2ce6061 WHIRLPOOL 855a4516e0864989bde077fe476778a1f33d60423a6fda1da442c4d0e76e727931d868fdb6fad140535a0398fac15ba555fe71fd418cfefea214b275d0e87404
diff --git a/app-vim/tcomment/tcomment-3.08.1.ebuild b/app-vim/tcomment/tcomment-3.08.1.ebuild
new file mode 100644
index 000000000000..ab0decbf1e3f
--- /dev/null
+++ b/app-vim/tcomment/tcomment-3.08.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tomtom/nerdtree.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
+LICENSE="GPL-3"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm -r README LICENSE.TXT etc spec addon* || die
+}
diff --git a/app-vim/tcomment/tcomment-9999.ebuild b/app-vim/tcomment/tcomment-9999.ebuild
new file mode 100644
index 000000000000..ab0decbf1e3f
--- /dev/null
+++ b/app-vim/tcomment/tcomment-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tomtom/nerdtree.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
+LICENSE="GPL-3"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm -r README LICENSE.TXT etc spec addon* || die
+}