summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimpress/vimpress-3.2.0.ebuild')
-rw-r--r--app-vim/vimpress/vimpress-3.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/vimpress/vimpress-3.2.0.ebuild b/app-vim/vimpress/vimpress-3.2.0.ebuild
new file mode 100644
index 000000000000..7d9e88b691d7
--- /dev/null
+++ b/app-vim/vimpress/vimpress-3.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: manage wordpress blogs from vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3510"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ dev-python/markdown"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"