summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild b/app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild
new file mode 100644
index 000000000000..68ed0060b73d
--- /dev/null
+++ b/app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting for udev rules files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1381"
+LICENSE="vim"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for udev.rules files. These files
+are automatically detected by filename; manual loading is also possible,
+via :set filetype=udev"
+
+PATCHES=( "${FILESDIR}/${P}-ftdetect.patch" )