summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/nerdtree/nerdtree-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/nerdtree/nerdtree-9999.ebuild b/app-vim/nerdtree/nerdtree-9999.ebuild
new file mode 100644
index 000000000000..54290f4ae099
--- /dev/null
+++ b/app-vim/nerdtree/nerdtree-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/scrooloose/nerdtree.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: A tree explorer plugin for navigating the filesystem"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1658 https://github.com/scrooloose/nerdtree"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="NERD_tree"
+
+src_prepare() {
+ rm LICENCE screenshot.png || die
+ default
+}