summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/gprbuild/files/gprbuild-2018-gentoo.patch11
-rw-r--r--dev-ada/gprbuild/gprbuild-2018-r3.ebuild9
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-ada/gprbuild/files/gprbuild-2018-gentoo.patch b/dev-ada/gprbuild/files/gprbuild-2018-gentoo.patch
index 1f967b61d4c7..34936ea1f52b 100644
--- a/dev-ada/gprbuild/files/gprbuild-2018-gentoo.patch
+++ b/dev-ada/gprbuild/files/gprbuild-2018-gentoo.patch
@@ -264,12 +264,21 @@
</configuration>
--- a/share/gprconfig/linker.xml 2018-10-17 21:36:15.856883517 +0200
+++ b/share/gprconfig/linker.xml 2018-10-17 21:35:15.985896804 +0200
+@@ -1025,7 +1025,7 @@
+ </targets>
+ <config>
+ for Library_Partial_Linker use
+- ("${PATH(ada)}${PREFIX(ada)}gcc", "-nostdlib", "-Wl,-r", "-o");
++ ("${PATH(ada)}${PREFIX(ada)}gcc-@VER@", "-nostdlib", "-Wl,-r", "-no-pie", "-o");
+ </config>
+ </configuration>
+
@@ -1044,7 +1044,7 @@
</targets>
<config>
for Library_Partial_Linker use
- ("${PATH(c)}${PREFIX(c)}gcc", "-nostdlib", "-Wl,-r", "-o");
-+ ("${PATH(c)}${PREFIX(c)}gcc-@VER@", "-nostdlib", "-Wl,-r", "-o");
++ ("${PATH(c)}${PREFIX(c)}gcc-@VER@", "-nostdlib", "-Wl,-r", "-no-pie", "-o");
</config>
</configuration>
diff --git a/dev-ada/gprbuild/gprbuild-2018-r3.ebuild b/dev-ada/gprbuild/gprbuild-2018-r3.ebuild
index 719ce8ae4725..a1157f5c3701 100644
--- a/dev-ada/gprbuild/gprbuild-2018-r3.ebuild
+++ b/dev-ada/gprbuild/gprbuild-2018-r3.ebuild
@@ -30,9 +30,7 @@ REQUIRED_USE="!gnat_2016 ^^ ( gnat_2017 gnat_2018 )"
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_prepare() {
- if use gnat_2016; then
- GCC_PV=4.9.4
- elif use gnat_2017; then
+ if use gnat_2017; then
GCC_PV=6.3.0
else
GCC_PV=7.3.1
@@ -49,10 +47,6 @@ src_prepare() {
-e "s:@GNATBIND@:gnatbind-${GCC_PV}:g" \
src/gprlib.adb \
|| die
-# sed -i \
-# -e "s:\"-Wl,-r\":\"-r\":g" \
-# share/gprconfig/linker.xml \
-# || die
}
src_configure() {
@@ -88,6 +82,5 @@ src_install() {
doins share/gprconfig/*
insinto /usr/share/gpr
doins share/_default.gpr
- insinto /usr/share/gprconfig
einstalldocs
}