summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch')
-rw-r--r--dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch20
1 files changed, 16 insertions, 4 deletions
diff --git a/dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch b/dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch
index d50a3405ee6c..c64ba2f65fa9 100644
--- a/dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch
+++ b/dev-cpp/commoncpp2/files/1.8.1-autoconf-update.patch
@@ -1,5 +1,3 @@
-diff --git a/configure.ac b/configure.ac
-index 80518db..64221e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,8 @@
@@ -12,7 +10,7 @@ index 80518db..64221e0 100644
AC_CONFIG_MACRO_DIR([m4])
m4_pattern_allow(LT_VERSION)
-@@ -81,17 +82,17 @@ fi
+@@ -81,17 +82,17 @@
AC_SUBST(ccincludedir)
AC_CONFIG_AUX_DIR(autoconf)
@@ -34,7 +32,21 @@ index 80518db..64221e0 100644
AC_C_RESTRICT
AC_C_VOLATILE
-@@ -408,10 +409,11 @@ LIB_MAJOR=`echo $LT_VERSION | sed -e 's/[:].*$//'`
+@@ -395,10 +396,11 @@
+ #endif
+
+ ])
+-
++AC_ARG_WITH([doxygen],
++ AS_HELP_STRING([--without-doxygen], [Do not build documentation]))
+ AC_PATH_PROG(DOXYGEN, doxygen, no)
+ AC_SUBST(DOXYGEN)
+-AM_CONDITIONAL(DOXY, test "$DOXYGEN" != "no")
++AM_CONDITIONAL([DOXY], [test "x$with_doxygen" != "xno"])
+
+ AM_CONDITIONAL(GETOPT_LONG, [test ! -z "$LIBGETOPTOBJS"])
+
+@@ -408,10 +410,11 @@
AC_SUBST(LIB_VERSION)
AC_SUBST(LIB_MAJOR)