summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libcmis/libcmis-9999.ebuild')
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild36
1 files changed, 16 insertions, 20 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index a060dbb78ee9..1d4b60e4cd0e 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,25 +1,34 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
inherit git-r3
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
-inherit autotools flag-o-matic
+inherit autotools
DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="https://github.com/tdf/libcmis"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.5"
+SLOT="0/0.6"
+IUSE="man test tools"
-IUSE="man static-libs test tools"
+RESTRICT="test"
+DEPEND="
+ dev-libs/boost:=
+ dev-libs/libxml2
+ net-misc/curl
+"
+RDEPEND="${DEPEND}
+ !dev-cpp/libcmis:0.5
+"
BDEPEND="
virtual/pkgconfig
man? (
@@ -31,14 +40,6 @@ BDEPEND="
dev-util/cppunit
)
"
-DEPEND="
- dev-libs/boost:=
- dev-libs/libxml2
- net-misc/curl
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
src_prepare() {
default
@@ -46,14 +47,9 @@ src_prepare() {
}
src_configure() {
- # bug 618778
- append-cxxflags -std=c++14
-
local myeconfargs=(
- --program-suffix=-$(ver_cut 1-2)
--disable-werror
$(use_with man)
- $(use_enable static-libs static)
$(use_enable test tests)
$(use_enable tools client)
)