summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libcmis')
-rw-r--r--dev-cpp/libcmis/libcmis-0.5.2_pre20160820-r1.ebuild7
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-cpp/libcmis/libcmis-0.5.2_pre20160820-r1.ebuild b/dev-cpp/libcmis/libcmis-0.5.2_pre20160820-r1.ebuild
index ef3f07753294..8377602271d8 100644
--- a/dev-cpp/libcmis/libcmis-0.5.2_pre20160820-r1.ebuild
+++ b/dev-cpp/libcmis/libcmis-0.5.2_pre20160820-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ elif [[ ${PV} = *_pre* ]]; then
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
-inherit alternatives autotools ${SCM_ECLASS}
+inherit alternatives autotools flag-o-matic ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="C++ client library for the CMIS interface"
@@ -59,6 +59,9 @@ src_prepare() {
}
src_configure() {
+ # bug 618778
+ append-cxxflags -std=c++14
+
econf \
--program-suffix=-${SLOT} \
--disable-werror \
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 603a0334c7de..78e5b1990a3a 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ elif [[ ${PV} = *_pre* ]]; then
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
-inherit alternatives autotools ${SCM_ECLASS}
+inherit alternatives autotools flag-o-matic ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="C++ client library for the CMIS interface"
@@ -57,6 +57,9 @@ src_prepare() {
}
src_configure() {
+ # bug 618778
+ append-cxxflags -std=c++14
+
econf \
--program-suffix=-${SLOT} \
--disable-werror \