summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild')
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild b/dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild
index 4084b8771570..025c5aad888e 100644
--- a/dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild
+++ b/dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_P="LucenePlusPlus-rel_${PV}"
inherit cmake
@@ -9,18 +9,17 @@ inherit cmake
DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="|| ( LGPL-3 Apache-2.0 )"
SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
+KEYWORDS="amd64 ~hppa ~loong ppc ppc64 sparc x86"
IUSE="debug"
-DEPEND="dev-libs/boost:=[zlib]"
-RDEPEND="${DEPEND}"
-
RESTRICT="test"
-S="${WORKDIR}/${MY_P}"
+DEPEND="dev-libs/boost:=[zlib]"
+RDEPEND="${DEPEND}"
DOCS=( AUTHORS README.rst )