summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/lucene++/lucene++-3.0.7.ebuild')
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-cpp/lucene++/lucene++-3.0.7.ebuild b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
deleted file mode 100644
index 7041d7913dce..000000000000
--- a/dev-cpp/lucene++/lucene++-3.0.7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_P="LucenePlusPlus-rel_${PV}"
-inherit cmake-utils multilib
-
-DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
-HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
-SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( LGPL-3 Apache-2.0 )"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
-IUSE="debug"
-
-DEPEND="dev-libs/boost:="
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( AUTHORS README.rst )
-
-PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DEMO=OFF
- -DENABLE_TEST=OFF
- )
-
- cmake-utils_src_configure
-}