summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tclap/tclap-1.2.2.ebuild')
-rw-r--r--dev-cpp/tclap/tclap-1.2.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/tclap/tclap-1.2.2.ebuild b/dev-cpp/tclap/tclap-1.2.2.ebuild
new file mode 100644
index 000000000000..53fcd8f85956
--- /dev/null
+++ b/dev-cpp/tclap/tclap-1.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple templatized C++ library for parsing command line arguments"
+HOMEPAGE="http://tclap.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}