summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/websocketpp/websocketpp-0.5.0.ebuild')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
new file mode 100644
index 000000000000..6d334bd4909a
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# tests no-op
+RESTRICT="test"
+
+src_configure() {
+ # Disable EXAMPLES as compilation is broken upstream
+ local mycmakeargs=(
+ -DEXAMPLES=OFF
+ $(cmake-utils_use_enable !boost CPP11)
+ $(cmake-utils_use_enable test TESTS)
+ )
+
+ cmake-utils_src_configure
+}