summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/websocketpp')
-rw-r--r--dev-cpp/websocketpp/Manifest2
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.4.0.ebuild35
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.5.0.ebuild35
3 files changed, 0 insertions, 72 deletions
diff --git a/dev-cpp/websocketpp/Manifest b/dev-cpp/websocketpp/Manifest
index a4d4a562e59a..5bcfe300fb3d 100644
--- a/dev-cpp/websocketpp/Manifest
+++ b/dev-cpp/websocketpp/Manifest
@@ -1,3 +1 @@
-DIST websocketpp-0.4.0.tar.gz 628675 SHA256 8634b233c0c47afa6b76c4edcb9694de490b33950c549fd2531b312c18e8cfca SHA512 770560afca5f9c88454c1aec61e5c4dfd38b3835897a96c3815fe1232ba6ef7622d07530d644055e60089d5c6f8ab383691358abf2da5782515ad9f313f1d253 WHIRLPOOL 2fa0f3deabe6c7b5ae22ea5d4e2f90367a68b816cf4ffe81d61b7f9b85ef575c1cc1baadbf685e9c58ea3f442136c3d1128585e7244498b9def0484995015926
-DIST websocketpp-0.5.0.tar.gz 642592 SHA256 ab032d61f1d94fc4ebf3bb74297e520499d6fe56801084d3cc828455482e81d9 SHA512 8c254a3dc772fce31e4dff58e352d967d47d64cfb07dd93d1da7707f27c43760bf2c3d1e43b7669dad20b7986159185e5ba26d87e1716fb896be23173438c947 WHIRLPOOL 719921a8e804a382020d507ebe33bb5779191cc756b92cf9bd5a576370d4824100ddba556b96a3cbe88f9d701e28e6471727ad34f268805006f03ae3b99e39e0
DIST websocketpp-0.6.0.tar.gz 655641 SHA256 688c52772b90a4694496c08f4ec1d712e24af17dc060d3392f0f3b4e18062898 SHA512 55dbb8d1666ae0d35d4b46ec2c375c9d3d66f57a473f526175a63bc147279c12bd8e605e5812a68ef45d8b6f51f4cfd6e61a1b971d223b5dc6e5528a6937fef8 WHIRLPOOL 3a179a7066e15fe08c3b1fc54b320729437ad5894a07e5ae630e992e34b740b817c78b9869f281fd4d2a7c54b6cca60fa9a1773803b6d67f5fb11c2694348ac5
diff --git a/dev-cpp/websocketpp/websocketpp-0.4.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.4.0.ebuild
deleted file mode 100644
index bca41a7d0422..000000000000
--- a/dev-cpp/websocketpp/websocketpp-0.4.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="C++/Boost Asio based websocket client/server library"
-HOMEPAGE="http://www.zaphoyd.com/websocketpp"
-SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
-SLOT="0"
-IUSE="boost test"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- boost? ( dev-libs/boost )
-"
-
-# tests no-op
-RESTRICT="test"
-
-src_configure() {
- # Disable EXAMPLES as compilation is broken upstream
- local mycmakeargs=(
- -DEXAMPLES=OFF
- $(cmake-utils_use_enable !boost CPP11)
- $(cmake-utils_use_enable test)
- )
-
- cmake-utils_src_configure
-}
diff --git a/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
deleted file mode 100644
index 6d334bd4909a..000000000000
--- a/dev-cpp/websocketpp/websocketpp-0.5.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="C++/Boost Asio based websocket client/server library"
-HOMEPAGE="http://www.zaphoyd.com/websocketpp"
-SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
-SLOT="0"
-IUSE="boost test"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- boost? ( dev-libs/boost )
-"
-
-# tests no-op
-RESTRICT="test"
-
-src_configure() {
- # Disable EXAMPLES as compilation is broken upstream
- local mycmakeargs=(
- -DEXAMPLES=OFF
- $(cmake-utils_use_enable !boost CPP11)
- $(cmake-utils_use_enable test TESTS)
- )
-
- cmake-utils_src_configure
-}