summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.60.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index f34956b15c13..bfb9e401d24d 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,3 +1,4 @@
DIST glibmm-2.56.1.tar.xz 6841240 BLAKE2B db0e1402f322fd31138cf4db2fc2fabb6fb9896f226f98bd524fe005f0e3412f6973774571b7ec79a9e3c79f6622b0969a55dc91631cc996906dd1e558ad4fe8 SHA512 fd5ad19c5dcba484573520e1d00b5bbb600ee805ab8cd9c0d985880cc1bcbe67ad31fa9f2b5789b5892eddd6be345e3f308593e5ef021e1cfda132e4235fb735
DIST glibmm-2.58.1.tar.xz 6778632 BLAKE2B e51e43cb9361147627c2ffc4c232bd8b15d935cc3a20a4fa8d98f5be9c45f7dd635aab69177d033cf65a6e39cee53bcc723be56cc8db966e88b00b5f9cb1f29a SHA512 c1a67412e6de3853557318cd921e6e73874a14ffd3cb51fc158b0d45fb1d5c2560e011b3b0be7f8cf8afee13952e824625d832e5237288b974c2ba20a6f042cb
DIST glibmm-2.60.0.tar.xz 6874840 BLAKE2B 4d71bb394fe88d0a6b0286b1d9651e6063957f7d4adca6af16b2e5698d8f87984f37257c879fa4b655a03519d6adf6400695197d29e0dd14552ac3bf174f60e3 SHA512 ea0477d5cb6e59019e87f929630ff32ac38dd5e4fb53fe84ef64b5b41c1090c8e10a0a67b26c786ab4d9ebf64b993fa0044333b4aa8554c331a0a6d02039c5ad
+DIST glibmm-2.60.1.tar.xz 7132072 BLAKE2B 8d25287b7805d7196bffa909447db0e0fa0edd1c243b3ccdef91f1a6573ea0723cda8e88993e878e6c8440b23488b0ab8c9ed727bd4e2d4a46f56ba251510aa0 SHA512 89f1d10bd9b60232519e2e13c02b0b1010dacbe67a8bab06c3a5873649e5090ed3593d518bfd8e12933a08aaa5fc654b1475efc208e2256c7efd197274a28b79
diff --git a/dev-cpp/glibmm/glibmm-2.60.1.ebuild b/dev-cpp/glibmm/glibmm-2.60.1.ebuild
new file mode 100644
index 000000000000..d742fe267822
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.60.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.59.2:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ # don't build examples - we want to install example sources, not binaries
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable debug debug-refcounting) \
+ $(multilib_native_use_enable doc documentation) \
+ --enable-deprecated-api
+}
+
+multilib_src_test() {
+ cd tests
+ default
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
+ dodoc -r examples
+}