summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/websocketpp/Manifest1
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.7.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/Manifest b/dev-cpp/websocketpp/Manifest
index 5bcfe300fb3d..5c1fd661d25a 100644
--- a/dev-cpp/websocketpp/Manifest
+++ b/dev-cpp/websocketpp/Manifest
@@ -1 +1,2 @@
DIST websocketpp-0.6.0.tar.gz 655641 SHA256 688c52772b90a4694496c08f4ec1d712e24af17dc060d3392f0f3b4e18062898 SHA512 55dbb8d1666ae0d35d4b46ec2c375c9d3d66f57a473f526175a63bc147279c12bd8e605e5812a68ef45d8b6f51f4cfd6e61a1b971d223b5dc6e5528a6937fef8 WHIRLPOOL 3a179a7066e15fe08c3b1fc54b320729437ad5894a07e5ae630e992e34b740b817c78b9869f281fd4d2a7c54b6cca60fa9a1773803b6d67f5fb11c2694348ac5
+DIST websocketpp-0.7.0.tar.gz 682271 SHA256 07b3364ad30cda022d91759d4b83ff902e1ebadb796969e58b59caa535a03923 SHA512 91a86d4f5120db3f474169bb146f865f82167b1e9eedabec8793b31005e4ce3d22083283bc1b9f9e37fa0da835addcb2b68260a27c753852c06b3b1bb2f3c12e WHIRLPOOL 2ea92ac5eeb4ea0b20413e7feb52bd4aab7a46f920684a640d96ce23111cea3fa2b98194181a5ba75a3f9bb1669ee0766b9a4e445348ac1d328f82c1405c2c0a
diff --git a/dev-cpp/websocketpp/websocketpp-0.7.0.ebuild b/dev-cpp/websocketpp/websocketpp-0.7.0.ebuild
new file mode 100644
index 000000000000..38e0e1eb8552
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost examples test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CPP11="$(usex !boost)"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use examples && DOCS=( examples/ )
+ cmake-utils_src_install
+}