summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/luabind/luabind-0.9.1-r1.ebuild62
-rw-r--r--dev-cpp/luabind/metadata.xml1
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-cpp/luabind/luabind-0.9.1-r1.ebuild b/dev-cpp/luabind/luabind-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..93d952d97c1d
--- /dev/null
+++ b/dev-cpp/luabind/luabind-0.9.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# NOTE: cross compiling is probably broken
+
+EAPI=6
+
+inherit eutils multilib
+
+DESCRIPTION="Creates bindings for lua on c++"
+HOMEPAGE="http://www.rasterbar.com/products/luabind.html"
+SRC_URI="mirror://sourceforge/luabind/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/boost-build"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-boost.patch
+)
+
+src_prepare() {
+ default
+
+ # backwardscomapt with old boost-build-1.49.0
+ if [[ -e $(which bjam-1_49 2>/dev/null) ]] ; then
+ my_bjam_bin=bjam-1_49
+ else
+ my_bjam_bin=bjam
+ fi
+}
+
+src_compile() {
+ # linkflags get appended, so they actually do nothing
+ ${my_bjam_bin} release \
+ -d+2 \
+ --prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
+ cflags="${CFLAGS}" \
+ linkflags="${LDFLAGS}" \
+ link=shared || die "compile failed"
+}
+
+src_install() {
+ ${my_bjam_bin} release \
+ -d+2 \
+ --prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
+ cflags="${CFLAGS}" \
+ linkflags="${LDFLAGS}" \
+ link=shared \
+ install || die "install failed"
+}
+
+# generally, this really sucks, patches welcome
diff --git a/dev-cpp/luabind/metadata.xml b/dev-cpp/luabind/metadata.xml
index e3a6d3f4a063..6486ff1b527f 100644
--- a/dev-cpp/luabind/metadata.xml
+++ b/dev-cpp/luabind/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="sourceforge">luabind</remote-id>
</upstream>