summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/notcurses/notcurses-2.2.3.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-cpp/notcurses/notcurses-2.2.3.ebuild b/dev-cpp/notcurses/notcurses-2.2.3.ebuild
index e605c199a795..8cf6e10a7538 100644
--- a/dev-cpp/notcurses/notcurses-2.2.3.ebuild
+++ b/dev-cpp/notcurses/notcurses-2.2.3.ebuild
@@ -8,11 +8,11 @@ inherit cmake-multilib
DESCRIPTION="Blingful TUIs and character graphics"
HOMEPAGE="https://notcurses.com"
-SRC_URI="https://github.com/dankamongmen/notcurses/archive/v${PV}.tar.gz -> ${P}.tar.gz doc? ( https://github.com/dankamongmen/notcurses/releases/download/v${PV}/notcurses-doc-${PV}.tar.gz )"
+SRC_URI="https://github.com/dankamongmen/notcurses/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/dankamongmen/notcurses/releases/download/v${PV}/notcurses-doc-${PV}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+doc"
DEPEND="dev-libs/libunistring
media-video/ffmpeg
@@ -40,12 +40,11 @@ src_test() {
src_install() {
cmake-multilib_src_install
- if use doc ; then
- # we use this tortured form lest we try, every time we release a
- # x.y.1 or x.y.3, to install the source dir as a man page.
- # exploit the fact that there's a bijection from html<>man.
- for i in ../*.html ; do
- doman ../$(basename $i .html)
- done
- fi
+
+ # we use this tortured form lest we try, every time we release a
+ # x.y.1 or x.y.3, to install the source dir as a man page.
+ # exploit the fact that there's a bijection from html<>man.
+ for i in ../*.html ; do
+ doman ../$(basename $i .html)
+ done
}