summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/apgdiff')
-rw-r--r--dev-db/apgdiff/Manifest5
-rw-r--r--dev-db/apgdiff/apgdiff-1.4.ebuild51
-rw-r--r--dev-db/apgdiff/apgdiff-2.2.1.ebuild51
-rw-r--r--dev-db/apgdiff/apgdiff-2.2.2.ebuild51
-rw-r--r--dev-db/apgdiff/apgdiff-2.3.ebuild51
-rw-r--r--dev-db/apgdiff/apgdiff-2.4.ebuild51
-rw-r--r--dev-db/apgdiff/metadata.xml8
7 files changed, 268 insertions, 0 deletions
diff --git a/dev-db/apgdiff/Manifest b/dev-db/apgdiff/Manifest
new file mode 100644
index 000000000000..985b111038a9
--- /dev/null
+++ b/dev-db/apgdiff/Manifest
@@ -0,0 +1,5 @@
+DIST apgdiff-1.4-src.zip 178608 SHA256 aa341a627e2087eb9fb66c1bc0a785e5e9953459395b60e1b447ed30947f52f9 SHA512 c1dcd3f39e931f90e65a439a610d5b264b790419a59b2c90f6d9107c1b5151c602887588f378110a2e9420428414fc333c7919e2137e2dc35168654ceb3ae8d0 WHIRLPOOL 2e05303fef00b999aa07dce0b59df7d805b486cced61ac50a40c3b8aefcdd37aec649feb4f5fc96111d388029198def0aada0d33c6421e672a652d19b55f94a1
+DIST apgdiff-2.2.1-src.zip 194305 SHA256 844c92499f80b52d290fa89edf19c955e056eb6d92ee7fb3ad01acfcc04b4d04 SHA512 cab6b2349d5822ca579c1e021ea7f02f5ddf39d56559f841d0cadfdccc1c1c61399c494302ea5909984b9a8a6d91cf08868f012dd3487a8633f65e3bbd28f19c WHIRLPOOL 364f78e22c136e10acd3337db7d7b85ef16e33042d7d6fae990824fda583d94189ebd737c6268fb1264f7b9d2fa11c3c4852fd8fab89cfbca6cd42c7bfb97397
+DIST apgdiff-2.2.2-src.zip 198814 SHA256 cd4c4a5315fdf311e3dd18c1368a50fead91bb17198e984b0d4ace15755a55ae SHA512 273ba473b5b4ccfe2ae1b3f34ce2c2b825e446fad166f28a4575528190c20922e6794563ae3e5b2918ade5a3292a792ea363e9e5ec0900e924332d8771548c0b WHIRLPOOL ee6af8b7444676e4eb887f716dee3514f9d5a5d54bf0efa859c20c817424a5dbcf4059dc6641c1fa19c53441c25e002e812d5eea13d3c4aecce6fee76a46dd9e
+DIST apgdiff-2.3-src.zip 215881 SHA256 bbae469988ca321b76a4d2d8717477261c823ac9608282998cec28ed8933c8b2 SHA512 e716143ff4378fc27c4781076c51826583c2ad9dab17f4364acbfed0f9a0958dca0de9a72171816bbce41653ad33834158cb9277dd8790649da4bd24e013bbb5 WHIRLPOOL e404000074fee973b49ace8f6223072eb4aca95283d9a3ffd9b4dec1f242de263546e0894b8242828368926a45ba3ac5388b59cb4be73a1b0421a9e1703f2685
+DIST apgdiff-2.4-src.zip 227714 SHA256 8551a3e10c7aae3a04efc5dad655575484b63a3323f07db5e81c50b42d88129c SHA512 f37e0f86ff8a8bc53a43cac1748ab3a2c96ab6c972b37ee63f281ee397b31a7b48986cbc963d89ea773f1bb7b10b798de74a4c88a03f2db7672501b93355261b WHIRLPOOL 61a8a605508564188f16fc306abd710e3895079a53a2f311e3cbb8b1943146f7f4039b31f5f5653b1ea30447a2e35328201d7aec7b91952483c1a5a18704d3b7
diff --git a/dev-db/apgdiff/apgdiff-1.4.ebuild b/dev-db/apgdiff/apgdiff-1.4.ebuild
new file mode 100644
index 000000000000..688ade64018b
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Another PostgreSQL Diff Tool is a simple PostgreSQL diff tool that is useful for schema upgrades"
+HOMEPAGE="http://apgdiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.5
+ >=dev-java/ant-core-1.7.0:0
+ >=dev-java/ant-junit-1.7.0:0
+ app-arch/zip:0
+ test? (
+ dev-java/hamcrest-core:0
+ >=dev-java/junit-4.4:4
+ )"
+
+RDEPEND=">=virtual/jre-1.5"
+
+java_prepare() {
+ mkdir "${S}"/lib
+ cd "${S}"/lib
+ if use test ; then
+ java-pkg_jar-from --build-only hamcrest-core
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ eant -Dnoget=true jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ java-pkg_dolauncher apgdiff --jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dnoget=true test
+}
diff --git a/dev-db/apgdiff/apgdiff-2.2.1.ebuild b/dev-db/apgdiff/apgdiff-2.2.1.ebuild
new file mode 100644
index 000000000000..bbfae5428360
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-2.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Another PostgreSQL Diff Tool is a simple PostgreSQL diff tool that is useful for schema upgrades"
+HOMEPAGE="http://apgdiff.com"
+SRC_URI="http://apgdiff.com/download/${P}-src.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.6
+ >=dev-java/ant-core-1.7.0:0
+ >=dev-java/ant-junit-1.7.0:0
+ app-arch/zip:0
+ test? (
+ dev-java/hamcrest-core:1.3
+ >=dev-java/junit-4.4:4
+ )"
+
+RDEPEND=">=virtual/jre-1.6"
+
+java_prepare() {
+ mkdir "${S}"/lib
+ cd "${S}"/lib
+ if use test ; then
+ java-pkg_jar-from --build-only hamcrest-core-1.3
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ eant -Dnoget=true jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ java-pkg_dolauncher apgdiff --jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dnoget=true test
+}
diff --git a/dev-db/apgdiff/apgdiff-2.2.2.ebuild b/dev-db/apgdiff/apgdiff-2.2.2.ebuild
new file mode 100644
index 000000000000..d3b7362f9d4c
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-2.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Another PostgreSQL Diff Tool is a simple PostgreSQL diff tool that is useful for schema upgrades"
+HOMEPAGE="http://apgdiff.com"
+SRC_URI="http://apgdiff.com/download/${P}-src.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.6
+ >=dev-java/ant-core-1.7.0:0
+ >=dev-java/ant-junit-1.7.0:0
+ app-arch/zip:0
+ test? (
+ dev-java/hamcrest-core:0
+ >=dev-java/junit-4.4:4
+ )"
+
+RDEPEND=">=virtual/jre-1.6"
+
+java_prepare() {
+ mkdir "${S}"/lib
+ cd "${S}"/lib
+ if use test ; then
+ java-pkg_jar-from --build-only hamcrest-core
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ eant -Dnoget=true jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ java-pkg_dolauncher apgdiff --jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dnoget=true test
+}
diff --git a/dev-db/apgdiff/apgdiff-2.3.ebuild b/dev-db/apgdiff/apgdiff-2.3.ebuild
new file mode 100644
index 000000000000..d3b7362f9d4c
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Another PostgreSQL Diff Tool is a simple PostgreSQL diff tool that is useful for schema upgrades"
+HOMEPAGE="http://apgdiff.com"
+SRC_URI="http://apgdiff.com/download/${P}-src.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.6
+ >=dev-java/ant-core-1.7.0:0
+ >=dev-java/ant-junit-1.7.0:0
+ app-arch/zip:0
+ test? (
+ dev-java/hamcrest-core:0
+ >=dev-java/junit-4.4:4
+ )"
+
+RDEPEND=">=virtual/jre-1.6"
+
+java_prepare() {
+ mkdir "${S}"/lib
+ cd "${S}"/lib
+ if use test ; then
+ java-pkg_jar-from --build-only hamcrest-core
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ eant -Dnoget=true jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ java-pkg_dolauncher apgdiff --jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dnoget=true test
+}
diff --git a/dev-db/apgdiff/apgdiff-2.4.ebuild b/dev-db/apgdiff/apgdiff-2.4.ebuild
new file mode 100644
index 000000000000..d3b7362f9d4c
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-2.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Another PostgreSQL Diff Tool is a simple PostgreSQL diff tool that is useful for schema upgrades"
+HOMEPAGE="http://apgdiff.com"
+SRC_URI="http://apgdiff.com/download/${P}-src.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.6
+ >=dev-java/ant-core-1.7.0:0
+ >=dev-java/ant-junit-1.7.0:0
+ app-arch/zip:0
+ test? (
+ dev-java/hamcrest-core:0
+ >=dev-java/junit-4.4:4
+ )"
+
+RDEPEND=">=virtual/jre-1.6"
+
+java_prepare() {
+ mkdir "${S}"/lib
+ cd "${S}"/lib
+ if use test ; then
+ java-pkg_jar-from --build-only hamcrest-core
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ eant -Dnoget=true jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ java-pkg_dolauncher apgdiff --jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dnoget=true test
+}
diff --git a/dev-db/apgdiff/metadata.xml b/dev-db/apgdiff/metadata.xml
new file mode 100644
index 000000000000..407583277d87
--- /dev/null
+++ b/dev-db/apgdiff/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<maintainer>
+ <email>java@gentoo.org</email>
+</maintainer>
+</pkgmetadata>