summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild
index 91c76012d1da..94b9034c1074 100644
--- a/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-2.12.21.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit dotnet autotools base
+WANT_AUTOMAKE="1.11"
+inherit autotools dotnet
-SLOT="2"
-DESCRIPTION="gtk bindings for mono"
-LICENSE="GPL-2"
+DESCRIPTION="GTK bindings for mono"
HOMEPAGE="http://www.mono-project.com/GtkSharp"
-KEYWORDS="amd64 x86"
SRC_URI="http://download.mono-project.com/sources/gtk-sharp212/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="amd64 x86"
IUSE="debug"
RESTRICT="test"
@@ -30,33 +32,31 @@ RDEPEND="
!dev-dotnet/glib-sharp
!dev-dotnet/glade-sharp
!dev-dotnet/pango-sharp
- !dev-dotnet/atk-sharp"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/automake:1.11"
+ !dev-dotnet/atk-sharp
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${PN}-2.12.21-mono-ambiguous-range.patch"
)
src_prepare() {
- base_src_prepare
+ default
+
eautoreconf
- libtoolize
}
src_configure() {
- econf --disable-static \
+ econf \
+ --disable-static \
--disable-maintainer-mode \
$(use_enable debug)
}
-src_compile() {
- emake
-}
-
src_install() {
default
+
dotnet_multilib_comply
sed -i "s/\\r//g" "${D}"/usr/bin/* || die "sed failed"
}