summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/nuget/Manifest1
-rw-r--r--dev-dotnet/nuget/files/add-keyfile-option-to-csproj.patch11
-rw-r--r--dev-dotnet/nuget/files/rsa-4096.snkbin0 -> 596 bytes
-rw-r--r--dev-dotnet/nuget/files/strongnames-for-ebuild-2.8.1.patch34
-rw-r--r--dev-dotnet/nuget/metadata.xml7
-rw-r--r--dev-dotnet/nuget/nuget-2.8.3.ebuild61
-rw-r--r--dev-dotnet/xdt-for-monodevelop/Manifest1
-rw-r--r--dev-dotnet/xdt-for-monodevelop/files/add-keyfile-option-to-csproj.patch13
-rw-r--r--dev-dotnet/xdt-for-monodevelop/files/disable-testproject-build-in-sln.patch12
-rw-r--r--dev-dotnet/xdt-for-monodevelop/files/rsa-4096.snkbin0 -> 596 bytes
-rw-r--r--dev-dotnet/xdt-for-monodevelop/metadata.xml7
-rw-r--r--dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.3.ebuild45
12 files changed, 192 insertions, 0 deletions
diff --git a/dev-dotnet/nuget/Manifest b/dev-dotnet/nuget/Manifest
new file mode 100644
index 000000000000..13bcc9b86c7e
--- /dev/null
+++ b/dev-dotnet/nuget/Manifest
@@ -0,0 +1 @@
+DIST nuget-2.8.3.tar.gz 14240757 SHA256 8ca0cc2e3ec753338472011c8591c2e4d924e81bd12d9fab1c24d5a4903c61ec SHA512 a1447042f77fdb0d63caaf49d64208ac0ab072ab1caf7f5edaeb936f3e26fac7ad80c3af51b12086cb2b9bb63df32e8da244894c4cd4946373ff86cb7a4e130d WHIRLPOOL cc4cb8fb7f8e92f756c5aa05022e6cca843cace591cfe3f8ea585f286d4002eb8b255cf8946cd9c3e3b3945480ddfe30868b4ad1e069329bb59f8b37051cf990
diff --git a/dev-dotnet/nuget/files/add-keyfile-option-to-csproj.patch b/dev-dotnet/nuget/files/add-keyfile-option-to-csproj.patch
new file mode 100644
index 000000000000..25ccbd491826
--- /dev/null
+++ b/dev-dotnet/nuget/files/add-keyfile-option-to-csproj.patch
@@ -0,0 +1,11 @@
+--- work.orig/nuget-Release-2.8.1-MonoDevelop/src/Core/Core.csproj 2014-10-29 13:28:28.000000000 +0300
++++ work/nuget-Release-2.8.1-MonoDevelop/src/Core/Core.csproj 2015-03-06 10:55:17.783762949 +0300
+@@ -12,6 +12,8 @@
+ <TargetFrameworkProfile Condition=" '$(MonoBuild)' == '' And '$(TargetFrameworkVersion)' == 'v4.0' "></TargetFrameworkProfile>
+ <PlatformTarget>AnyCPU</PlatformTarget>
+ <TargetFrameworkVersion>v4.0</TargetFrameworkVersion>
++ <SignAssembly>true</SignAssembly>
++ <AssemblyOriginatorKeyFile>rsa-4096.snk</AssemblyOriginatorKeyFile>
+ </PropertyGroup>
+ <ItemGroup>
+ <EmbeddedResource Include="..\..\Common\CommonResources.resx">
diff --git a/dev-dotnet/nuget/files/rsa-4096.snk b/dev-dotnet/nuget/files/rsa-4096.snk
new file mode 100644
index 000000000000..380116c18fc3
--- /dev/null
+++ b/dev-dotnet/nuget/files/rsa-4096.snk
Binary files differ
diff --git a/dev-dotnet/nuget/files/strongnames-for-ebuild-2.8.1.patch b/dev-dotnet/nuget/files/strongnames-for-ebuild-2.8.1.patch
new file mode 100644
index 000000000000..40c35c8cd4c8
--- /dev/null
+++ b/dev-dotnet/nuget/files/strongnames-for-ebuild-2.8.1.patch
@@ -0,0 +1,34 @@
+--- work.unpacked/nuget-Release-2.8.1-MonoDevelop/src/Core/Core.csproj 2015-03-06 18:32:27.255819553 +0300
++++ work/nuget-Release-2.8.1-MonoDevelop/src/Core/Core.csproj 2015-03-06 18:51:33.240779088 +0300
+@@ -221,9 +221,7 @@
+ <Compile Include="Utility\VersionSpec.cs" />
+ <Compile Include="Utility\WebRequestEventArgs.cs" />
+ <Compile Include="FileModifiers\XdtTransformer.cs" />
+- <Reference Include="Microsoft.Web.XmlTransform">
+- <HintPath>..\..\lib\Microsoft.Web.XmlTransform.dll</HintPath>
+- </Reference>
++ <Reference Include="Microsoft.Web.XmlTransform, Version=2.8.1.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756" />
+ <Reference Include="System" />
+ <Reference Include="System.ComponentModel.DataAnnotations" />
+ <Reference Include="System.Core" />
+--- work.unpacked/nuget-Release-2.8.1-MonoDevelop/src/CommandLine/CommandLine.csproj 2015-03-06 18:32:27.265819553 +0300
++++ work/nuget-Release-2.8.1-MonoDevelop/src/CommandLine/CommandLine.csproj 2015-03-06 18:52:00.471778127 +0300
+@@ -30,10 +35,6 @@
+ <Reference Include="Microsoft.Build.Engine" />
+ <Reference Include="Microsoft.Build.Framework" />
+ <Reference Include="Microsoft.CSharp" />
+- <Reference Include="Microsoft.Web.XmlTransform, Version=1.0.0.0, Culture=neutral, processorArchitecture=MSIL">
+- <SpecificVersion>False</SpecificVersion>
+- <HintPath>..\..\lib\Microsoft.Web.XmlTransform.dll</HintPath>
+- </Reference>
+ <Reference Include="System" />
+ <Reference Include="System.ComponentModel.Composition" />
+ <Reference Include="System.ComponentModel.DataAnnotations" />
+@@ -41,6 +42,7 @@
+ <Reference Include="System.Xml.Linq" />
+ <Reference Include="System.Xml" />
+ <Reference Include="WindowsBase" />
++ <Reference Include="Microsoft.Web.XmlTransform, Version=2.8.1.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756" />
+ </ItemGroup>
+ <ItemGroup>
+ <Compile Include="..\..\Common\MsBuildProjectUtility.cs">
diff --git a/dev-dotnet/nuget/metadata.xml b/dev-dotnet/nuget/metadata.xml
new file mode 100644
index 000000000000..64172775ecd6
--- /dev/null
+++ b/dev-dotnet/nuget/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <use>
+ </use>
+</pkgmetadata>
diff --git a/dev-dotnet/nuget/nuget-2.8.3.ebuild b/dev-dotnet/nuget/nuget-2.8.3.ebuild
new file mode 100644
index 000000000000..a66d865c930c
--- /dev/null
+++ b/dev-dotnet/nuget/nuget-2.8.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit dotnet eutils
+
+DESCRIPTION="Nuget - .NET Package Manager"
+HOMEPAGE="http://nuget.codeplex.com"
+SRC_URI="https://github.com/mrward/nuget/archive/Release-${PV}-MonoDevelop.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/nuget-Release-${PV}-MonoDevelop
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+# Mask 3.2.0 because of mcs compiler bug : http://stackoverflow.com/a/17926731/238232
+# it fixed in 3.2.3
+DEPEND=">=dev-lang/mono-3.2.3
+ <=dev-dotnet/xdt-for-monodevelop-2.8.2"
+RDEPEND="${DEPEND}"
+
+# note about blocking nuget:
+# there are at least two versions of it - on from mono, one from mrward
+# see https://bugzilla.xamarin.com/show_bug.cgi?id=27693
+# i think version from mrward is enough for now,
+# that is why there is no slotted install or two different names/locations
+
+pkg_setup() {
+ dotnet_pkg_setup
+ mozroots --import --sync --machine
+}
+
+src_prepare() {
+ sed -i -e 's@RunTests@ @g' "${S}/Build/Build.proj" || die
+ cp "${FILESDIR}/rsa-4096.snk" "${S}/src/Core/" || die
+ epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
+ sed -i -E -e "s#(\[assembly: InternalsVisibleTo(.*)\])#/* \1 */#g" "src/Core/Properties/AssemblyInfo.cs" || die
+ epatch "${FILESDIR}/strongnames-for-ebuild-2.8.1.patch"
+}
+
+src_configure() {
+ export EnableNuGetPackageRestore="true"
+}
+
+src_compile() {
+# xbuild Build/Build.proj /p:Configuration=Release /p:TreatWarningsAsErrors=false /tv:4.0 /p:TargetFrameworkVersion="v${FRAMEWORK}" /p:Configuration="Mono Release" /t:GoMono || die
+ source ./build.sh || die
+}
+
+src_install() {
+ elog "Installing NuGet.Core.dll into GAC"
+ egacinstall "src/Core/obj/Mono Release/NuGet.Core.dll"
+ elog "Installing NuGet console application"
+ insinto /usr/lib/mono/NuGet/"${FRAMEWORK}"/
+ doins src/CommandLine/obj/Mono\ Release/NuGet.exe
+ make_wrapper nuget "mono /usr/lib/mono/NuGet/${FRAMEWORK}/NuGet.exe"
+}
diff --git a/dev-dotnet/xdt-for-monodevelop/Manifest b/dev-dotnet/xdt-for-monodevelop/Manifest
new file mode 100644
index 000000000000..cc4ad97146fd
--- /dev/null
+++ b/dev-dotnet/xdt-for-monodevelop/Manifest
@@ -0,0 +1 @@
+DIST xdt-for-monodevelop-2.8.3.tar.gz 50974 SHA256 fb1a92dd745ca564d7179113bef6ca4e719d75583b33ca2bc65b74ce89c5d3c4 SHA512 3770b1ad8aab9c85e0b93bbf42415130b83eccf766fee5a2d08fe276af01cbf31ff4ab4cac661df982587e5b83b8efc8cd733a79bc387d666526aeb146f79f02 WHIRLPOOL 75fcc1b9054de7c8f6ed0e99ea3cb40e1d60fbaa4a077c86ed018ed462ceb2194111133e6a66a46e503eb5cd6230e3d1c96d97ed0c2572e0571c872b501eb099
diff --git a/dev-dotnet/xdt-for-monodevelop/files/add-keyfile-option-to-csproj.patch b/dev-dotnet/xdt-for-monodevelop/files/add-keyfile-option-to-csproj.patch
new file mode 100644
index 000000000000..5deedce4cdc0
--- /dev/null
+++ b/dev-dotnet/xdt-for-monodevelop/files/add-keyfile-option-to-csproj.patch
@@ -0,0 +1,13 @@
+--- work.unpacked/xdt-Release-NuGet-2.8.1-Mono/XmlTransform/Microsoft.Web.XmlTransform.csproj 2014-10-26 21:16:30.000000000 +0300
++++ work/xdt-Release-NuGet-2.8.1-Mono/XmlTransform/Microsoft.Web.XmlTransform.csproj 2015-03-06 16:51:31.859038709 +0300
+@@ -16,7 +16,9 @@
+ <PropertyGroup Condition="!$(ExtensionsCommonTargetsExists)">
+ <AppDesignerFolder>Properties</AppDesignerFolder>
+ <TargetFrameworkVersion>v4.0</TargetFrameworkVersion>
+- </PropertyGroup>
++ <SignAssembly>true</SignAssembly>
++ <AssemblyOriginatorKeyFile>rsa-4096.snk</AssemblyOriginatorKeyFile>
++ </PropertyGroup>
+ <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Debug|AnyCPU' AND !$(ExtensionsCommonTargetsExists)">
+ <DebugSymbols>true</DebugSymbols>
+ <DebugType>full</DebugType>
diff --git a/dev-dotnet/xdt-for-monodevelop/files/disable-testproject-build-in-sln.patch b/dev-dotnet/xdt-for-monodevelop/files/disable-testproject-build-in-sln.patch
new file mode 100644
index 000000000000..a6513f5cd718
--- /dev/null
+++ b/dev-dotnet/xdt-for-monodevelop/files/disable-testproject-build-in-sln.patch
@@ -0,0 +1,12 @@
+--- work.unpacked/xdt-Release-NuGet-2.8.1-Mono/Microsoft.Web.XmlTransform.sln 2014-10-26 21:16:30.000000000 +0300
++++ work/xdt-Release-NuGet-2.8.1-Mono/Microsoft.Web.XmlTransform.sln 2015-03-06 16:29:38.736085076 +0300
+@@ -12,9 +12,7 @@
+ EndGlobalSection
+ GlobalSection(ProjectConfigurationPlatforms) = postSolution
+ {22AC988D-26C0-43A9-8EB1-102DA31F0F8F}.Debug|Any CPU.ActiveCfg = Debug|Any CPU
+- {22AC988D-26C0-43A9-8EB1-102DA31F0F8F}.Debug|Any CPU.Build.0 = Debug|Any CPU
+ {22AC988D-26C0-43A9-8EB1-102DA31F0F8F}.Release|Any CPU.ActiveCfg = Release|Any CPU
+- {22AC988D-26C0-43A9-8EB1-102DA31F0F8F}.Release|Any CPU.Build.0 = Release|Any CPU
+ {0684EE2A-6F30-4BC7-B5E7-8CBA15534E06}.Debug|Any CPU.ActiveCfg = Debug|Any CPU
+ {0684EE2A-6F30-4BC7-B5E7-8CBA15534E06}.Debug|Any CPU.Build.0 = Debug|Any CPU
+ {0684EE2A-6F30-4BC7-B5E7-8CBA15534E06}.Release|Any CPU.ActiveCfg = Release|Any CPU
diff --git a/dev-dotnet/xdt-for-monodevelop/files/rsa-4096.snk b/dev-dotnet/xdt-for-monodevelop/files/rsa-4096.snk
new file mode 100644
index 000000000000..380116c18fc3
--- /dev/null
+++ b/dev-dotnet/xdt-for-monodevelop/files/rsa-4096.snk
Binary files differ
diff --git a/dev-dotnet/xdt-for-monodevelop/metadata.xml b/dev-dotnet/xdt-for-monodevelop/metadata.xml
new file mode 100644
index 000000000000..64172775ecd6
--- /dev/null
+++ b/dev-dotnet/xdt-for-monodevelop/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <use>
+ </use>
+</pkgmetadata>
diff --git a/dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.3.ebuild b/dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.3.ebuild
new file mode 100644
index 000000000000..811cade9e5bf
--- /dev/null
+++ b/dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit dotnet eutils
+
+DESCRIPTION="Microsoft's Xml Document Transformation library"
+HOMEPAGE="https://github.com/mrward/xdt"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+SRC_URI="https://github.com/mrward/xdt/archive/Release-NuGet-${PV}-Mono.tar.gz -> xdt-for-monodevelop-${PV}.tar.gz"
+S=${WORKDIR}/xdt-Release-NuGet-${PV}-Mono
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="|| ( dev-lang/mono )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ dotnet_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/disable-testproject-build-in-sln.patch"
+ cp "${FILESDIR}/rsa-4096.snk" "${S}/XmlTransform" || die
+ epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
+ sed -i -e "s/1.0.0/${PV}/g" "${S}/XmlTransform/Properties/AssemblyInfo.cs" || die
+}
+
+src_configure() {
+ export EnableNuGetPackageRestore="true"
+}
+
+src_compile() {
+ exbuild Microsoft.Web.XmlTransform.sln
+}
+
+src_install() {
+ elog "Installing Microsoft.Web.XmlTransform.dll to GAC"
+ egacinstall XmlTransform/bin/Release/Microsoft.Web.XmlTransform.dll
+}